summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 00:21:34 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 00:21:34 +0000
commitf80ebe268bf68933d47fa2e4ef71122ba9ff1d0e (patch)
treec45f920ac8ec3359478d0ff366c43a885e1af2ad /dev-lang
parentstable on x86 (diff)
downloadgentoo-2-f80ebe268bf68933d47fa2e4ef71122ba9ff1d0e.tar.gz
gentoo-2-f80ebe268bf68933d47fa2e4ef71122ba9ff1d0e.tar.bz2
gentoo-2-f80ebe268bf68933d47fa2e4ef71122ba9ff1d0e.zip
add USE=nocxx support
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.1.3-r1.ebuild3
-rw-r--r--dev-lang/python/python-2.2.3-r6.ebuild9
-rw-r--r--dev-lang/python/python-2.3.4-r1.ebuild6
-rw-r--r--dev-lang/python/python-2.3.5.ebuild6
-rw-r--r--dev-lang/python/python-2.4-r3.ebuild6
-rw-r--r--dev-lang/python/python-2.4.1.ebuild12
6 files changed, 19 insertions, 23 deletions
diff --git a/dev-lang/python/python-2.1.3-r1.ebuild b/dev-lang/python/python-2.1.3-r1.ebuild
index 2d89e155ce16..4ac663a9160f 100644
--- a/dev-lang/python/python-2.1.3-r1.ebuild
+++ b/dev-lang/python/python-2.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.19 2005/05/21 08:25:33 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.3-r1.ebuild,v 1.20 2005/05/28 00:21:34 vapier Exp $
IUSE="readline tcltk berkdb"
@@ -19,7 +19,6 @@ DEPEND="virtual/libc >=sys-libs/zlib-1.1.3
readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
berkdb? ( >=sys-libs/db-3 )
tcltk? ( >=dev-lang/tk-8.0 )"
-RDEPEND="$DEPEND"
# The dev-python/python-fchksum RDEPEND is needed to that this python provides
# the functionality expected from previous pythons.
diff --git a/dev-lang/python/python-2.2.3-r6.ebuild b/dev-lang/python/python-2.2.3-r6.ebuild
index 5352533d4833..b2bbe9e425e9 100644
--- a/dev-lang/python/python-2.2.3-r6.ebuild
+++ b/dev-lang/python/python-2.2.3-r6.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r6.ebuild,v 1.1 2005/02/07 04:28:20 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r6.ebuild,v 1.2 2005/05/28 00:21:34 vapier Exp $
inherit flag-o-matic eutils python
-IUSE="berkdb bootstrap build doc gdbm ncurses readline ssl tcltk"
-
PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
S="${WORKDIR}/Python-${PV}"
DESCRIPTION="A really great language"
+HOMEPAGE="http://www.python.org"
SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tgz"
-HOMEPAGE="http://www.python.org"
LICENSE="PSF-2.2"
KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64"
+IUSE="berkdb bootstrap build doc gdbm ncurses readline ssl tcltk nocxx"
DEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
@@ -85,7 +84,7 @@ src_compile() {
local myopts
#if we are creating a new build image, we remove the dependency on g++
- if use build && ! use bootstrap
+ if use build && ! use bootstrap || use nocxx
then
myopts="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.4-r1.ebuild b/dev-lang/python/python-2.3.4-r1.ebuild
index 53d539bfd51e..96820a75ec55 100644
--- a/dev-lang/python/python-2.3.4-r1.ebuild
+++ b/dev-lang/python/python-2.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4-r1.ebuild,v 1.5 2005/05/01 15:28:15 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.4-r1.ebuild,v 1.6 2005/05/28 00:21:34 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -21,7 +21,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tar.bz2"
LICENSE="PSF-2.2"
SLOT="2.3"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc s390 sh sparc x86 ppc64"
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
+IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
DEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
@@ -103,7 +103,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if use build && ! use bootstrap; then
+ if use build && ! use bootstrap || use nocxx ; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index 50ceb39552e0..3cad0db65697 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.14 2005/05/18 13:09:36 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.15 2005/05/28 00:21:34 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -21,7 +21,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tar.bz2"
LICENSE="PSF-2.2"
SLOT="2.3"
KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 s390 sh sparc x86"
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
+IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
DEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
@@ -110,7 +110,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if use build && ! use bootstrap; then
+ if use build && ! use bootstrap || use nocxx ; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.4-r3.ebuild b/dev-lang/python/python-2.4-r3.ebuild
index 1515f97039c8..edd9598e6008 100644
--- a/dev-lang/python/python-2.4-r3.ebuild
+++ b/dev-lang/python/python-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.3 2005/04/20 18:48:48 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.4 2005/05/28 00:21:34 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -18,7 +18,7 @@ DESCRIPTION="A really great language"
SRC_URI="http://www.python.org/ftp/python/${PYVER}/${MY_P}.tar.bz2"
HOMEPAGE="http://www.python.org"
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
+IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
LICENSE="PSF-2.2"
SLOT="2.4"
@@ -117,7 +117,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if use build && ! use bootstrap; then
+ if use build && ! use bootstrap || use nocxx ; then
myconf="--with-cxx=no"
fi
diff --git a/dev-lang/python/python-2.4.1.ebuild b/dev-lang/python/python-2.4.1.ebuild
index 7773397d5e50..2652a4499098 100644
--- a/dev-lang/python/python-2.4.1.ebuild
+++ b/dev-lang/python/python-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.4 2005/05/07 16:36:19 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.1.ebuild,v 1.5 2005/05/28 00:21:34 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -17,17 +17,15 @@ PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="Python is an interpreted, interactive, object-orientated programming language."
+HOMEPAGE="http://www.python.org/"
SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2"
-HOMEPAGE="http://www.python.org"
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc"
LICENSE="PSF-2.2"
SLOT="2.4"
-
KEYWORDS="~x86 ~ppc ~sparc ~arm ~hppa ~amd64 ~s390 ~alpha ~ia64 ~mips"
+IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X uclibc nocxx"
-DEPEND="virtual/libc
- >=sys-libs/zlib-1.1.3
+DEPEND=">=sys-libs/zlib-1.1.3
!dev-python/cjkcodecs
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
@@ -118,7 +116,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if use build && ! use bootstrap; then
+ if use build && ! use bootstrap || use nocxx ; then
myconf="--with-cxx=no"
fi