summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-24 01:35:09 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-24 01:35:09 +0000
commit0cc9dfc45281b0e9c78a83bda15a3aa119f9b049 (patch)
treec37f9970f6522b0d5b433c0882737878e68d8370 /dev-libs/STLport
parentStable on ppc. (diff)
downloadgentoo-2-0cc9dfc45281b0e9c78a83bda15a3aa119f9b049.tar.gz
gentoo-2-0cc9dfc45281b0e9c78a83bda15a3aa119f9b049.tar.bz2
gentoo-2-0cc9dfc45281b0e9c78a83bda15a3aa119f9b049.zip
Added patch for compilation-failure on ppc (bug #132054, thanks to illusion)
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'dev-libs/STLport')
-rw-r--r--dev-libs/STLport/ChangeLog6
-rw-r--r--dev-libs/STLport/STLport-5.1.0.ebuild7
-rw-r--r--dev-libs/STLport/files/STLport-5.1.0-ppc.patch21
3 files changed, 31 insertions, 3 deletions
diff --git a/dev-libs/STLport/ChangeLog b/dev-libs/STLport/ChangeLog
index a7f03155b08a..c8b19d572d5e 100644
--- a/dev-libs/STLport/ChangeLog
+++ b/dev-libs/STLport/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/STLport
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.34 2006/12/24 01:03:44 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/ChangeLog,v 1.35 2006/12/24 01:35:09 dev-zero Exp $
+
+ 24 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+ +files/STLport-5.1.0-ppc.patch, STLport-5.1.0.ebuild:
+ Added patch for compilation-failure on ppc (bug #132054, thanks to illusion)
24 Dec 2006; Tiziano Müller <dev-zero@gentoo.org> STLport-5.1.0.ebuild:
Added large file support (bug #146242, thanks to Hanno Meyer-Thurow)
diff --git a/dev-libs/STLport/STLport-5.1.0.ebuild b/dev-libs/STLport/STLport-5.1.0.ebuild
index dcab32293e06..ff7f7a8e74cf 100644
--- a/dev-libs/STLport/STLport-5.1.0.ebuild
+++ b/dev-libs/STLport/STLport-5.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.0.ebuild,v 1.2 2006/12/24 01:03:44 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/STLport/STLport-5.1.0.ebuild,v 1.3 2006/12/24 01:35:09 dev-zero Exp $
-inherit versionator eutils toolchain-funcs multilib flag-o-matic
+inherit eutils versionator eutils toolchain-funcs multilib flag-o-matic
KEYWORDS="~amd64 ~x86"
@@ -20,6 +20,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ # It should be save to apply this on non-ppc systems as well
+ epatch "${FILESDIR}/${P}-ppc.patch"
+
sed -i \
-e 's/\(OPT += \)-O2/\1/' \
build/Makefiles/gmake/*cc.mak \
diff --git a/dev-libs/STLport/files/STLport-5.1.0-ppc.patch b/dev-libs/STLport/files/STLport-5.1.0-ppc.patch
new file mode 100644
index 000000000000..1376d8e83d92
--- /dev/null
+++ b/dev-libs/STLport/files/STLport-5.1.0-ppc.patch
@@ -0,0 +1,21 @@
+--- stlport/stl/config/_gcc.h.orig 2006-12-24 02:38:24.000000000 +0100
++++ stlport/stl/config/_gcc.h 2006-12-24 02:40:20.000000000 +0100
+@@ -9,6 +9,7 @@
+ # ifndef _STLP_USE_GLIBC
+ # define _STLP_USE_GLIBC 1
+ # endif
++# define _STLP_NO_VENDOR_STDLIB_L
+ # if defined (__UCLIBC__) && !defined (_STLP_USE_UCLIBC)
+ # define _STLP_USE_UCLIBC 1
+ # endif
+@@ -21,7 +22,9 @@
+ #endif
+
+ #if (__GNUC__ < 3)
+-# define _STLP_NO_VENDOR_STDLIB_L
++# ifndef _STLP_NO_VENDOR_STDLIB_L
++# define _STLP_NO_VENDOR_STDLIB_L
++# endif
+ #endif
+
+ /* We guess if we are using the cygwin distrib that has a special include schema.