summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-10-27 20:06:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-10-27 20:06:23 +0000
commit9bc7c13ee741c304a7587ccf07353b67abe083d0 (patch)
tree5190356e9b76a81ac851123baa2ea6ea3c19d641 /dev-libs/angelscript
parentEnable in source build, fixes bug #526726. (diff)
downloadgentoo-2-9bc7c13ee741c304a7587ccf07353b67abe083d0.tar.gz
gentoo-2-9bc7c13ee741c304a7587ccf07353b67abe083d0.tar.bz2
gentoo-2-9bc7c13ee741c304a7587ccf07353b67abe083d0.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-libs/angelscript')
-rw-r--r--dev-libs/angelscript/ChangeLog8
-rw-r--r--dev-libs/angelscript/angelscript-2.29.2.ebuild57
-rw-r--r--dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch13
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-libs/angelscript/ChangeLog b/dev-libs/angelscript/ChangeLog
index eba28fca5baf..66337c954a77 100644
--- a/dev-libs/angelscript/ChangeLog
+++ b/dev-libs/angelscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/angelscript
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/angelscript/ChangeLog,v 1.20 2014/07/24 20:12:56 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/angelscript/ChangeLog,v 1.21 2014/10/27 20:06:23 hasufell Exp $
+
+*angelscript-2.29.2 (27 Oct 2014)
+
+ 27 Oct 2014; Julian Ospald <hasufell@gentoo.org> +angelscript-2.29.2.ebuild,
+ +files/angelscript-2.29.2-execstack.patch:
+ version bump
*angelscript-2.29.1 (24 Jul 2014)
diff --git a/dev-libs/angelscript/angelscript-2.29.2.ebuild b/dev-libs/angelscript/angelscript-2.29.2.ebuild
new file mode 100644
index 000000000000..ef462eb1b4c1
--- /dev/null
+++ b/dev-libs/angelscript/angelscript-2.29.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/angelscript/angelscript-2.29.2.ebuild,v 1.1 2014/10/27 20:06:23 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="A flexible, cross-platform scripting library"
+HOMEPAGE="http://www.angelcode.com/angelscript/"
+SRC_URI="http://www.angelcode.com/angelscript/sdk/files/angelscript_${PV}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/sdk
+S2=${WORKDIR}/sdk_static
+
+pkg_setup() {
+ tc-export CXX AR RANLIB
+}
+
+src_prepare() {
+ if use static-libs ; then
+ cp -pR "${WORKDIR}"/sdk "${S2}"/ || die
+ fi
+ epatch "${FILESDIR}"/${P}-execstack.patch
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ einfo "Shared build"
+ emake -C ${PN}/projects/gnuc SHARED=1 VERSION=${PV}
+
+ if use static-libs ; then
+ einfo "Static build"
+ emake -C ${PN}/projects/gnuc
+ fi
+}
+
+multilib_src_install() {
+ doheader ${PN}/include/angelscript.h
+ dolib.so ${PN}/lib/libangelscript-${PV}.so
+ dosym libangelscript-${PV}.so /usr/$(get_libdir)/libangelscript.so
+
+ if use static-libs ; then
+ dolib.a ${PN}/lib/libangelscript.a
+ fi
+}
+
+multilib_src_install_all() {
+ use doc && dohtml -r "${WORKDIR}"/sdk/docs/*
+}
diff --git a/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch b/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch
new file mode 100644
index 000000000000..2cdb6696dd70
--- /dev/null
+++ b/dev-libs/angelscript/files/angelscript-2.29.2-execstack.patch
@@ -0,0 +1,13 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Mar 23 13:45:39 UTC 2014
+Subject: fix RWX sections
+
+--- a/sdk/angelscript/source/as_callfunc_arm_gcc.S
++++ b/sdk/angelscript/source/as_callfunc_arm_gcc.S
+@@ -696,3 +696,6 @@
+
+ #endif /* arm */
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif