summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-22 21:22:43 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-22 21:22:43 +0000
commit51475aa09ff4e49992376fd9c076efcfa1e3743e (patch)
tree812b4517b39d8d6155c195f876f22ade27816f52 /dev-libs/apr
parentUse openrc to background daemons instead of internal support. (diff)
downloadgentoo-2-51475aa09ff4e49992376fd9c076efcfa1e3743e.tar.gz
gentoo-2-51475aa09ff4e49992376fd9c076efcfa1e3743e.tar.bz2
gentoo-2-51475aa09ff4e49992376fd9c076efcfa1e3743e.zip
Generate & use local libtool #374355 by Justin Lecher.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/ChangeLog8
-rw-r--r--dev-libs/apr/apr-1.5.0-r1.ebuild114
-rw-r--r--dev-libs/apr/files/apr-1.5.0-libtool.patch17
3 files changed, 138 insertions, 1 deletions
diff --git a/dev-libs/apr/ChangeLog b/dev-libs/apr/ChangeLog
index 79d82e17f9ea..fbc92bbfe5f0 100644
--- a/dev-libs/apr/ChangeLog
+++ b/dev-libs/apr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/apr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.203 2014/01/21 00:12:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/ChangeLog,v 1.204 2014/01/22 21:22:43 vapier Exp $
+
+*apr-1.5.0-r1 (22 Jan 2014)
+
+ 22 Jan 2014; Mike Frysinger <vapier@gentoo.org> +apr-1.5.0-r1.ebuild,
+ +files/apr-1.5.0-libtool.patch:
+ Generate & use local libtool #374355 by Justin Lecher.
21 Jan 2014; Mike Frysinger <vapier@gentoo.org> apr-1.4.8-r1.ebuild,
apr-1.5.0.ebuild:
diff --git a/dev-libs/apr/apr-1.5.0-r1.ebuild b/dev-libs/apr/apr-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..da1613feca6e
--- /dev/null
+++ b/dev-libs/apr/apr-1.5.0-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-1.5.0-r1.ebuild,v 1.1 2014/01/22 21:22:43 vapier Exp $
+
+EAPI="4"
+
+inherit autotools eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility static-libs +urandom"
+
+RDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
+ elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.0-mint.patch
+ epatch "${FILESDIR}"/${PN}-1.4.8-libtool.patch
+
+ # Apply user patches, bug #449048
+ epatch_user
+
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ epatch "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf
+
+ [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+ if tc-is-cross-compiler; then
+ export apr_cv_tcp_nodelay_with_cork="yes"
+ fi
+
+ if use urandom; then
+ myconf+=" --with-devrandom=/dev/urandom"
+ elif (( ${CHOST#*-hpux11.} <= 11 )); then
+ : # no /dev/*random on hpux11.11 and before, $PN detects this.
+ else
+ myconf+=" --with-devrandom=/dev/random"
+ fi
+
+ if [[ ${CHOST} == *-mint* ]] ; then
+ myconf+=" --disable-dso"
+ fi
+
+ # shl_load does not search runpath, but hpux11 supports dlopen
+ [[ ${CHOST} == *-hpux11* ]] && myconf="${myconf} --enable-dso=dlfcn"
+
+ if [[ ${CHOST} == *-solaris2.10 ]]; then
+ case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
+ *atomic_cas_ptr*) ;;
+ *)
+ elog "You do not have Solaris Patch ID "$(
+ [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
+ )" (Problem 4954703) installed on your host ($(hostname)),"
+ elog "using generic atomic operations instead."
+ myconf="${myconf} --disable-nonportable-atomics"
+ ;;
+ esac
+ fi
+
+ CONFIG_SHELL="${EPREFIX}"/bin/bash econf \
+ --enable-layout=gentoo \
+ --enable-nonportable-atomics \
+ --enable-threads \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -exec rm -f {} +
+
+ if use doc; then
+ dohtml -r docs/dox/html/*
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.a" -exec rm -f {} +
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ # Even in Prefix, we don't need this on AIX.
+ rm -f "${ED}usr/$(get_libdir)/apr.exp"
+}
diff --git a/dev-libs/apr/files/apr-1.5.0-libtool.patch b/dev-libs/apr/files/apr-1.5.0-libtool.patch
new file mode 100644
index 000000000000..5368a2689bdf
--- /dev/null
+++ b/dev-libs/apr/files/apr-1.5.0-libtool.patch
@@ -0,0 +1,17 @@
+generate a local copy of libtool for use in compiling
+
+https://bugs.gentoo.org/374355
+
+--- a/configure.in
++++ b/configure.in
+@@ -260,9 +260,7 @@ case $host in
+ fi
+ else
+ dnl libtoolize requires that the following not be indented
+- dnl should become LT_INIT(win32-dll)
+-AC_LIBTOOL_WIN32_DLL
+-AC_PROG_LIBTOOL
++LT_INIT(win32-dll)
+ # get libtool's setting of shlibpath_var
+ eval `grep "^shlibpath_var=[[A-Z_]]*$" $apr_builddir/libtool`
+ if test "x$shlibpath_var" = "x"; then