summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-01 10:53:30 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-01 10:53:30 +0000
commit0bfbf8474e959684252a81769958937bbce0fd1f (patch)
tree8d80c4eecdb725acc4b6d586508700299ad93c27 /dev-libs/atlas/atlas-3.5.11.ebuild
parentepatch, sed and changelog fixes (diff)
downloadgentoo-2-0bfbf8474e959684252a81769958937bbce0fd1f.tar.gz
gentoo-2-0bfbf8474e959684252a81769958937bbce0fd1f.tar.bz2
gentoo-2-0bfbf8474e959684252a81769958937bbce0fd1f.zip
moved 3.4.2 to stable, added latest development version (to stay keymasked)
Diffstat (limited to 'dev-libs/atlas/atlas-3.5.11.ebuild')
-rw-r--r--dev-libs/atlas/atlas-3.5.11.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/atlas/atlas-3.5.11.ebuild b/dev-libs/atlas/atlas-3.5.11.ebuild
new file mode 100644
index 000000000000..958e5f4186c5
--- /dev/null
+++ b/dev-libs/atlas/atlas-3.5.11.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/atlas/atlas-3.5.11.ebuild,v 1.1 2003/10/01 10:53:22 george Exp $
+
+IUSE=""
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software (BLAS implementation)"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/math-atlas/${PN}${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/ATLAS
+
+src_compile() {
+ # create a file answer to be redirected to make
+ echo "023" > answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ # the architecture of the processor is determined from the CFLAGS
+ case $CFLAGS in
+ *athlon*)
+ echo "AMD Athlon Processor Identified"
+ echo 2 >> answer;;
+ *pentiumpro*)
+ echo "Pentium Pro Processor Identified"
+ echo 3 >> answer;;
+ *pentium2*)
+ echo "Pentium II Processor Identified"
+ echo 4 >> answer;;
+ *pentium3*)
+ echo "Pentium III Processor Identified"
+ echo 5 >> answer;;
+ *pentium4*)
+ echo "Pentium IV Processor Identified"
+ echo 6 >> answer;;
+ *)
+ echo "Unknown Processor"
+ echo 1 >> answer;;
+ esac
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+ echo "" >> answer
+
+ make < answer || die
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+ make install arch=${ATLAS_ARCH} || die
+}
+
+src_install () {
+ # almost completely copied from the atlas-3.2.1-r1 ebuild
+ cd ${S}/lib/${ATLAS_ARCH}
+
+ insinto /usr/lib
+ dolib.a libatlas.a libcblas.a libf77blas.a liblapack.a
+
+ cd ${S}/include
+ insinto /usr/include
+ doins cblas.h clapack.h
+
+ cd ${S}
+
+ dodoc README INSTALL.txt
+ dodoc doc/*.txt
+ insinto /usr/share/doc/${PN}-${PV}
+ doins doc/*.ps
+ dodoc bin/${ATLAS_ARCH}/INSTALL_LOG/SUMMARY.LOG
+}