summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-08-25 03:06:51 +0000
committerAron Griffis <agriffis@gentoo.org>2005-08-25 03:06:51 +0000
commit734a00540388fc25015d5da622a0c7e26d10a2e3 (patch)
tree8f2a0e92cbfc939bc6540296e664c63f86222035 /dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild
parentMarking 2.10.4 stable (x86) (diff)
downloadgentoo-2-734a00540388fc25015d5da622a0c7e26d10a2e3.tar.gz
gentoo-2-734a00540388fc25015d5da622a0c7e26d10a2e3.tar.bz2
gentoo-2-734a00540388fc25015d5da622a0c7e26d10a2e3.zip
licq links against libcdk.a, so it needs to be build with -fPIC. Add
cdk-4.9.10.20020809-r1 ia64-only edition to force users to get the fix. Additionally add cdk-4.9.11.20031210-r2 (~arch) which turns on -fPIC for all arches. (Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild')
-rw-r--r--dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild b/dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild
new file mode 100644
index 000000000000..d92135036e68
--- /dev/null
+++ b/dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/cdk-4.9.11.20031210-r2.ebuild,v 1.1 2005/08/25 03:06:51 agriffis Exp $
+
+MY_P=${P/.2003/-2003}
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-devel/libtool"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # libcdk.a is linked into a shared object in licq
+ append-flags -fPIC
+
+ econf \
+ --with-ncurses --with-libtool \
+ || die "configure failed"
+
+ emake || die "make failed!"
+}
+
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ DOCUMENT_DIR=${D}/usr/share/doc/${MY_P} install \
+ || die "make install failed"
+}