summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-12-19 21:09:26 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-12-19 21:09:26 +0000
commitfabd5cbdfa4ea61cbdfdd3c3527076baefb28312 (patch)
treefa22c47dd2625786234fecec12bd8aaa45c22e07 /dev-libs/chmlib
parentFix for fortran detection, thanks alexxy poiting to it (diff)
downloadgentoo-2-fabd5cbdfa4ea61cbdfdd3c3527076baefb28312.tar.gz
gentoo-2-fabd5cbdfa4ea61cbdfdd3c3527076baefb28312.tar.bz2
gentoo-2-fabd5cbdfa4ea61cbdfdd3c3527076baefb28312.zip
Revision bump. Port to EAPI 3. Make examples optional, add static-libs USE
flag. Remove old. (Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/chmlib')
-rw-r--r--dev-libs/chmlib/ChangeLog11
-rw-r--r--dev-libs/chmlib/chmlib-0.39-r1.ebuild31
-rw-r--r--dev-libs/chmlib/chmlib-0.40-r1.ebuild27
-rw-r--r--dev-libs/chmlib/files/chmlib-0.39-headers.patch32
4 files changed, 36 insertions, 65 deletions
diff --git a/dev-libs/chmlib/ChangeLog b/dev-libs/chmlib/ChangeLog
index e2411f2c2055..b344f5a5e53a 100644
--- a/dev-libs/chmlib/ChangeLog
+++ b/dev-libs/chmlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/chmlib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/ChangeLog,v 1.15 2009/10/12 19:20:04 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/ChangeLog,v 1.16 2010/12/19 21:09:26 dirtyepic Exp $
+
+*chmlib-0.40-r1 (19 Dec 2010)
+
+ 19 Dec 2010; Ryan Hill <dirtyepic@gentoo.org> -chmlib-0.39-r1.ebuild,
+ -files/chmlib-0.39-headers.patch, +chmlib-0.40-r1.ebuild:
+ Revision bump. Port to EAPI 3. Make examples optional, add static-libs USE
+ flag. Remove old.
12 Oct 2009; Jeroen Roovers <jer@gentoo.org> chmlib-0.40.ebuild:
Stable for HPPA (bug #286604).
diff --git a/dev-libs/chmlib/chmlib-0.39-r1.ebuild b/dev-libs/chmlib/chmlib-0.39-r1.ebuild
deleted file mode 100644
index 58a8b1b445e2..000000000000
--- a/dev-libs/chmlib/chmlib-0.39-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/chmlib-0.39-r1.ebuild,v 1.6 2009/04/11 17:28:31 armin76 Exp $
-
-inherit eutils multilib flag-o-matic versionator
-
-DESCRIPTION="Library for MS CHM (compressed html) file format plus extracting and http server utils"
-HOMEPAGE="http://www.jedrea.com/chmlib/"
-SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 x86"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-stdtypes.patch
- epatch "${FILESDIR}"/${P}-headers.patch
-}
-
-src_compile() {
- econf --enable-examples || die "econf failed"
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS NEWS README
-}
diff --git a/dev-libs/chmlib/chmlib-0.40-r1.ebuild b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
new file mode 100644
index 000000000000..21e6b9f9eed6
--- /dev/null
+++ b/dev-libs/chmlib/chmlib-0.40-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/chmlib/chmlib-0.40-r1.ebuild,v 1.1 2010/12/19 21:09:26 dirtyepic Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Library for MS CHM (compressed html) file format"
+HOMEPAGE="http://www.jedrea.com/chmlib/"
+SRC_URI="http://www.jedrea.com/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples static-libs"
+
+DOCS=(AUTHORS NEWS README)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.39-stdtypes.patch
+ "${FILESDIR}"/${P}-headers.patch
+)
+
+src_configure() {
+ myeconfargs=($(use_enable examples))
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/chmlib/files/chmlib-0.39-headers.patch b/dev-libs/chmlib/files/chmlib-0.39-headers.patch
deleted file mode 100644
index 0b2421a867ce..000000000000
--- a/dev-libs/chmlib/files/chmlib-0.39-headers.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- src/chm_http.c
-+++ src/chm_http.c
-@@ -34,6 +34,7 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <unistd.h>
- #if __sun || __sgi
- #include <strings.h>
- #endif
-@@ -42,6 +43,7 @@
- #include <sys/socket.h>
- #include <sys/types.h>
- #include <netinet/in.h>
-+#include <arpa/inet.h>
-
- /* threading includes */
- #include <pthread.h>
---- src/extract_chmLib.c
-+++ src/extract_chmLib.c
-@@ -27,11 +27,7 @@
- #define snprintf _snprintf
- #define rindex strrchr
- #else
--#if __i386__
- #include <string.h>
--#else
--#include <strings.h>
--#endif
- #include <unistd.h>
- #include <sys/stat.h>
- #include <sys/types.h>