summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-06-18 21:39:38 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-06-18 21:39:38 +0000
commitca8589722ad2a20dd034df61166d5cbb7b6fb219 (patch)
tree2bd8868ac4fd8ce4d85b064eadc8310393c78586 /dev-libs/eggdbus/files
parentold (diff)
downloadgentoo-2-ca8589722ad2a20dd034df61166d5cbb7b6fb219.tar.gz
gentoo-2-ca8589722ad2a20dd034df61166d5cbb7b6fb219.tar.bz2
gentoo-2-ca8589722ad2a20dd034df61166d5cbb7b6fb219.zip
initial commit, package needed for policykit-0.92
(Portage version: 2.1.6.13/cvs/Linux ppc)
Diffstat (limited to 'dev-libs/eggdbus/files')
-rw-r--r--dev-libs/eggdbus/files/eggdbus-0.4-ldflags.patch11
-rw-r--r--dev-libs/eggdbus/files/eggdbus-0.4-tests.patch49
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/eggdbus/files/eggdbus-0.4-ldflags.patch b/dev-libs/eggdbus/files/eggdbus-0.4-ldflags.patch
new file mode 100644
index 000000000000..a98d96dec97f
--- /dev/null
+++ b/dev-libs/eggdbus/files/eggdbus-0.4-ldflags.patch
@@ -0,0 +1,11 @@
+--- configure.ac.old 2009-06-18 22:35:33.000000000 +0200
++++ configure.ac 2009-06-18 22:37:27.000000000 +0200
+@@ -119,7 +119,7 @@
+ AC_SUBST(DBUS_GLIB_CFLAGS)
+ AC_SUBST(DBUS_GLIB_LIBS)
+
+-if test "x$GCC" = "xyes"; then
++if test "x$GCC" = "xyes" && test "$USE_MAINTAINER_MODE" != no; then
+ LDFLAGS="-Wl,--as-needed $LDFLAGS"
+ fi
+
diff --git a/dev-libs/eggdbus/files/eggdbus-0.4-tests.patch b/dev-libs/eggdbus/files/eggdbus-0.4-tests.patch
new file mode 100644
index 000000000000..1aad6adde879
--- /dev/null
+++ b/dev-libs/eggdbus/files/eggdbus-0.4-tests.patch
@@ -0,0 +1,49 @@
+--- configure.ac.old 2009-06-18 22:35:33.000000000 +0200
++++ configure.ac 2009-06-19 00:42:02.000000000 +0200
+@@ -20,6 +20,7 @@
+ AC_ARG_ENABLE(ansi, [ --enable-ansi enable -ansi -pedantic gcc flags],enable_ansi=$enableval,enable_ansi=no)
+ AC_ARG_ENABLE(verbose-mode, [ --enable-verbose-mode support verbose debug mode],enable_verbose_mode=$enableval,enable_verbose_mode=$USE_MAINTAINER_MODE)
+ AC_ARG_ENABLE(man-pages, [ --enable-man-pages build manual pages],enable_man_pages=$enableval,enable_man_pages=yes)
++AC_ARG_ENABLE(tests, [ --enable-tests build tests],enable_tests=$enableval,enable_tests=$USE_MAINTAINER_MODE)
+
+ if test "${enable_man_page}" != no; then
+ dnl
+@@ -32,6 +33,8 @@
+ fi
+ AM_CONDITIONAL(MAN_PAGES_ENABLED, test x$enable_man_pages = xyes)
+
++AM_CONDITIONAL(BUILD_TESTS, test x$enable_tests = xyes)
++
+ GTK_DOC_CHECK([1.3])
+
+ #### gcc warning flags
+--- src/Makefile.am.old 2009-06-19 00:31:14.000000000 +0200
++++ src/Makefile.am 2009-06-19 00:32:19.000000000 +0200
+@@ -1,5 +1,11 @@
+
+-SUBDIRS = eggdbus tests
++SUBDIRS = eggdbus
++
++if BUILD_TESTS
++
++SUBDIRS += tests
++
++endif # BUILD_TESTS
+
+ clean-local :
+ rm -f *~
+--- docs/Makefile.am.old 2009-06-19 00:52:29.000000000 +0200
++++ docs/Makefile.am 2009-06-19 00:53:05.000000000 +0200
+@@ -1,5 +1,11 @@
+
+-SUBDIRS = man tests eggdbus
++SUBDIRS = man eggdbus
++
++if BUILD_TESTS
++
++SUBDIRS += tests
++
++endif # BUILD_TESTS
+
+ EXTRA_DIST = version.xml.in
+