summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-17 20:16:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-17 20:16:28 +0000
commitdef3d5433474a390db32576ee80dd0bd0208ba8f (patch)
treee6406dff948e9c58ec4cfba89e0b1ec1afb6effb /dev-libs/expat
parentstable x86, bug 279401 (diff)
downloadgentoo-2-def3d5433474a390db32576ee80dd0bd0208ba8f.tar.gz
gentoo-2-def3d5433474a390db32576ee80dd0bd0208ba8f.tar.bz2
gentoo-2-def3d5433474a390db32576ee80dd0bd0208ba8f.zip
Add patch for upstream bug #1990430.
(Portage version: 14076-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/ChangeLog10
-rw-r--r--dev-libs/expat/expat-2.0.1-r2.ebuild43
-rw-r--r--dev-libs/expat/files/expat-2.0.1-fix_bug_1990430.patch14
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-libs/expat/ChangeLog b/dev-libs/expat/ChangeLog
index bb6a203b8fc0..bca95af38bf0 100644
--- a/dev-libs/expat/ChangeLog
+++ b/dev-libs/expat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/expat
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.81 2009/03/23 15:43:31 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/ChangeLog,v 1.82 2009/08/17 20:16:28 arfrever Exp $
+
+*expat-2.0.1-r2 (17 Aug 2009)
+
+ 17 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +expat-2.0.1-r2.ebuild, +files/expat-2.0.1-fix_bug_1990430.patch:
+ Add patch for upstream bug #1990430.
23 Mar 2009; Peter Alfredsen <loki_val@gentoo.org> expat-2.0.1-r1.ebuild:
License is MIT per bug 263502, thanks to Justin Bronder
diff --git a/dev-libs/expat/expat-2.0.1-r2.ebuild b/dev-libs/expat/expat-2.0.1-r2.ebuild
new file mode 100644
index 000000000000..34a49935d63f
--- /dev/null
+++ b/dev-libs/expat/expat-2.0.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.0.1-r2.ebuild,v 1.1 2009/08/17 20:16:28 arfrever Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix segmentation fault in python tests (bug #197043)
+ epatch "${FILESDIR}/${P}-check_stopped_parser.patch"
+
+ epatch "${FILESDIR}/${P}-fix_bug_1990430.patch"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc Changes README || die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+}
+
+pkg_postinst() {
+ ewarn "Please note that the soname of the library changed!"
+ ewarn "If you are upgrading from a previous version you need"
+ ewarn "to fix dynamic linking inconsistencies by executing:"
+ ewarn "revdep-rebuild --library libexpat.so.0"
+}
diff --git a/dev-libs/expat/files/expat-2.0.1-fix_bug_1990430.patch b/dev-libs/expat/files/expat-2.0.1-fix_bug_1990430.patch
new file mode 100644
index 000000000000..17dc166a6956
--- /dev/null
+++ b/dev-libs/expat/files/expat-2.0.1-fix_bug_1990430.patch
@@ -0,0 +1,14 @@
+http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?view=log (1.13 -> 1.15)
+http://svn.python.org/view?view=rev&revision=74429
+
+--- lib/xmltok_impl.c
++++ lib/xmltok_impl.c
+@@ -1744,7 +1744,7 @@
+ const char *end,
+ POSITION *pos)
+ {
+- while (ptr != end) {
++ while (ptr < end) {
+ switch (BYTE_TYPE(enc, ptr)) {
+ #define LEAD_CASE(n) \
+ case BT_LEAD ## n: \