summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 10:42:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 10:42:42 +0000
commit0f041cb35ca9cdb50346975ec904d5a4081db841 (patch)
tree40962222823d1cee3950932cb23bb4972caf7532 /dev-libs/gjs
parentVersion bump for Gnome 3.16. (diff)
downloadgentoo-2-0f041cb35ca9cdb50346975ec904d5a4081db841.tar.gz
gentoo-2-0f041cb35ca9cdb50346975ec904d5a4081db841.tar.bz2
gentoo-2-0f041cb35ca9cdb50346975ec904d5a4081db841.zip
Version bump for Gnome 3.16. Clean up old revision.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/ChangeLog9
-rw-r--r--dev-libs/gjs/files/gjs-1.43.3-disable-unittest-1.patch40
-rw-r--r--dev-libs/gjs/files/gjs-1.43.3-disable-unittest-2.patch35
-rw-r--r--dev-libs/gjs/gjs-1.43.3.ebuild (renamed from dev-libs/gjs/gjs-1.40.1.ebuild)22
4 files changed, 96 insertions, 10 deletions
diff --git a/dev-libs/gjs/ChangeLog b/dev-libs/gjs/ChangeLog
index 7f68ee84b758..7859a71a2179 100644
--- a/dev-libs/gjs/ChangeLog
+++ b/dev-libs/gjs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/gjs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.68 2015/06/07 10:29:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.69 2015/06/09 10:42:42 eva Exp $
+
+*gjs-1.43.3 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> -gjs-1.40.1.ebuild,
+ +gjs-1.43.3.ebuild, +files/gjs-1.43.3-disable-unittest-1.patch,
+ +files/gjs-1.43.3-disable-unittest-2.patch:
+ Version bump for Gnome 3.16. Clean up old revision.
07 Jun 2015; Markus Meier <maekke@gentoo.org> gjs-1.42.0.ebuild:
arm stable, bug #534012
diff --git a/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-1.patch b/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-1.patch
new file mode 100644
index 000000000000..c6d740ad5537
--- /dev/null
+++ b/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-1.patch
@@ -0,0 +1,40 @@
+From 115c97bb07f71ac91e20b84f9da6389434d31999 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 12 Oct 2014 21:57:11 +0200
+Subject: [PATCH 1/2] Comment broken unittests
+
+---
+ test/gjs-tests.cpp | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/test/gjs-tests.cpp b/test/gjs-tests.cpp
+index 6cade7b..4d6c61e 100644
+--- a/test/gjs-tests.cpp
++++ b/test/gjs-tests.cpp
+@@ -324,18 +324,18 @@ main(int argc,
+
+ g_test_init(&argc, &argv, NULL);
+
+- g_test_add_func("/gjs/context/construct/destroy", gjstest_test_func_gjs_context_construct_destroy);
++ /* g_test_add_func("/gjs/context/construct/destroy", gjstest_test_func_gjs_context_construct_destroy); */
+ g_test_add_func("/gjs/context/construct/eval", gjstest_test_func_gjs_context_construct_eval);
+- g_test_add_func("/gjs/jsapi/util/array", gjstest_test_func_gjs_jsapi_util_array);
+- g_test_add_func("/gjs/jsapi/util/error/throw", gjstest_test_func_gjs_jsapi_util_error_throw);
+- g_test_add_func("/gjs/jsapi/util/string/js/string/utf8", gjstest_test_func_gjs_jsapi_util_string_js_string_utf8);
++ /* g_test_add_func("/gjs/jsapi/util/array", gjstest_test_func_gjs_jsapi_util_array); */
++ /* g_test_add_func("/gjs/jsapi/util/error/throw", gjstest_test_func_gjs_jsapi_util_error_throw); */
++ /* g_test_add_func("/gjs/jsapi/util/string/js/string/utf8", gjstest_test_func_gjs_jsapi_util_string_js_string_utf8); */
+ g_test_add_func("/gjs/jsutil/strip_shebang/no_shebang", gjstest_test_strip_shebang_no_advance_for_no_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/have_shebang", gjstest_test_strip_shebang_advance_for_shebang);
+ g_test_add_func("/gjs/jsutil/strip_shebang/only_shebang", gjstest_test_strip_shebang_return_null_for_just_shebang);
+ g_test_add_func("/util/glib/strv/concat/null", gjstest_test_func_util_glib_strv_concat_null);
+ g_test_add_func("/util/glib/strv/concat/pointers", gjstest_test_func_util_glib_strv_concat_pointers);
+
+- gjs_test_add_tests_for_coverage ();
++ /* gjs_test_add_tests_for_coverage (); */
+
+ g_test_run();
+
+--
+2.3.6
+
diff --git a/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-2.patch b/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-2.patch
new file mode 100644
index 000000000000..fe21f92dfc2b
--- /dev/null
+++ b/dev-libs/gjs/files/gjs-1.43.3-disable-unittest-2.patch
@@ -0,0 +1,35 @@
+From c9d63c7531a29418c64dc44556519d7bd1664ce4 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 12 Oct 2014 21:57:45 +0200
+Subject: [PATCH 2/2] Comment broken JS unittest
+
+---
+ installed-tests/js/testLocale.js | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/installed-tests/js/testLocale.js b/installed-tests/js/testLocale.js
+index b086a66..0c5abb1 100644
+--- a/installed-tests/js/testLocale.js
++++ b/installed-tests/js/testLocale.js
+@@ -1,14 +1,14 @@
+ // tests for JS_SetLocaleCallbacks().
+ const JSUnit = imports.jsUnit;
+
+-function testToLocaleDateString() {
+- let date = new Date();
++//function testToLocaleDateString() {
++ //let date = new Date();
+ // %A is the weekday name, this tests locale_to_unicode
+ // we're basically just testing for a non-crash, since
+ // we'd have to run in a specific locale to have any
+ // idea about the result.
+- date.toLocaleDateString("%A");
+-}
++ //date.toLocaleDateString("%A");
++//}
+
+ function testToLocaleLowerCase() {
+ JSUnit.assertEquals("aaa", "AAA".toLocaleLowerCase());
+--
+2.3.6
+
diff --git a/dev-libs/gjs/gjs-1.40.1.ebuild b/dev-libs/gjs/gjs-1.43.3.ebuild
index b9264704e879..2178e0ad1822 100644
--- a/dev-libs/gjs/gjs-1.40.1.ebuild
+++ b/dev-libs/gjs/gjs-1.43.3.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/gjs-1.40.1.ebuild,v 1.10 2014/10/11 11:44:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/gjs-1.43.3.ebuild,v 1.1 2015/06/09 10:42:42 eva Exp $
EAPI="5"
GCONF_DEBUG="no"
-inherit gnome2 pax-utils virtualx
+inherit eutils gnome2 pax-utils virtualx
DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="http://live.gnome.org/Gjs"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
SLOT="0"
IUSE="+cairo examples gtk test"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="
>=dev-libs/glib-2.36:2
- >=dev-libs/gobject-introspection-1.39.3
+ >=dev-libs/gobject-introspection-1.41.4
sys-libs/readline:0
dev-lang/spidermonkey:24
virtual/libffi
- cairo? ( x11-libs/cairo )
+ cairo? ( x11-libs/cairo[X] )
gtk? ( x11-libs/gtk+:3 )
"
DEPEND="${RDEPEND}
@@ -32,8 +32,12 @@ DEPEND="${RDEPEND}
test? ( sys-apps/dbus )
"
-# Large amount of tests are broken even in master.
-RESTRICT="test"
+src_prepare() {
+ # Disable broken unittests
+ epatch "${FILESDIR}"/${PN}-1.43.3-disable-unittest-*.patch
+
+ gnome2_src_prepare
+}
src_configure() {
# FIXME: add systemtap/dtrace support, like in glib:2