summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 20:18:15 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 20:18:15 +0000
commit59c8102492b0fde741fa01f055cfc53a861f7714 (patch)
treee697a8166d3446fa6efb3c9dc9452eede4db1de3 /dev-libs/igraph/igraph-0.6.4.ebuild
parentStable for amd64 wrt bug #457404 (diff)
downloadgentoo-2-59c8102492b0fde741fa01f055cfc53a861f7714.tar.gz
gentoo-2-59c8102492b0fde741fa01f055cfc53a861f7714.tar.bz2
gentoo-2-59c8102492b0fde741fa01f055cfc53a861f7714.zip
dev-libs/igraph: Version Bump; unbundle correctly and use pkg-config to detect sys libs, #445114; fix tests, #421773; drop old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-libs/igraph/igraph-0.6.4.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.6.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/igraph/igraph-0.6.4.ebuild b/dev-libs/igraph/igraph-0.6.4.ebuild
new file mode 100644
index 000000000000..6545d8483baa
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/igraph/igraph-0.6.4.ebuild,v 1.1 2013/02/21 20:18:15 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://igraph.sourceforge.net/index.html"
+SRC_URI="mirror://sourceforge/project/${PN}/C%20library/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug gmp static-libs"
+
+DEPEND="
+ dev-libs/libxml2
+ sci-libs/arpack
+ virtual/blas
+ virtual/lapack
+ sci-libs/cxsparse
+ sci-mathematics/glpk
+ gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-unbundle.patch )
+
+src_prepare() {
+# rm -rf src/{cs,f2c,lapack,f2c.h} optional/glpk || die
+# rm -rf src/cs optional/glpk || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gmp)
+ $(use_enable debug)
+ --disable-tls
+ --with-external-arpack
+ --with-external-blas
+ --with-external-lapack
+ --with-external-f2c
+ --with-external-glpk
+ )
+ autotools-utils_src_configure
+}