summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-02-09 22:31:04 +0000
committerChristian Heim <phreak@gentoo.org>2007-02-09 22:31:04 +0000
commitdb4d169dd913880d4f0bb2374fe5cfe084f938ce (patch)
tree3d5fb8fbef669205cbcdbe2d93a93b77c0ad890b /dev-libs/klibc
parentFix broken digest. Thanks to Benjamin Gehrels for reporting, closes bug #166124. (diff)
downloadgentoo-2-db4d169dd913880d4f0bb2374fe5cfe084f938ce.tar.gz
gentoo-2-db4d169dd913880d4f0bb2374fe5cfe084f938ce.tar.bz2
gentoo-2-db4d169dd913880d4f0bb2374fe5cfe084f938ce.zip
Quoting fixes, adding the -types.h patch suggested by Alon in #165472.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-libs/klibc')
-rw-r--r--dev-libs/klibc/ChangeLog6
-rw-r--r--dev-libs/klibc/files/klibc-1.4.13-types.h.patch12
-rw-r--r--dev-libs/klibc/klibc-1.4.13.ebuild39
3 files changed, 40 insertions, 17 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index da6d1d34309a..1935a0cc2d06 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.35 2007/01/20 10:58:43 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.36 2007/02/09 22:31:04 phreak Exp $
+
+ 09 Feb 2007; Christian Heim <phreak@gentoo.org>
+ +files/klibc-1.4.13-types.h.patch, klibc-1.4.13.ebuild:
+ Quoting fixes, adding the -types.h patch suggested by Alon in #165472.
20 Jan 2007; Christian Heim <phreak@gentoo.org>
-files/klibc-1.1.16-mips-ldpaths.patch, -files/klibc-1.1.16-mips32.patch,
diff --git a/dev-libs/klibc/files/klibc-1.4.13-types.h.patch b/dev-libs/klibc/files/klibc-1.4.13-types.h.patch
new file mode 100644
index 000000000000..f08ce2fbca23
--- /dev/null
+++ b/dev-libs/klibc/files/klibc-1.4.13-types.h.patch
@@ -0,0 +1,12 @@
+diff -urNp klibc-1.4.13.org/usr/include/sys/types.h klibc-1.4.13/usr/include/sys/types.h
+--- klibc-1.4.13.org/usr/include/sys/types.h 2006-07-25 23:55:23.000000000 +0300
++++ klibc-1.4.13/usr/include/sys/types.h 2007-02-07 15:24:03.000000000 +0200
+@@ -96,6 +96,8 @@ typedef uint32_t __bitwise __be32;
+ typedef uint64_t __bitwise __le64;
+ typedef uint64_t __bitwise __be64;
+
++typedef __u16 __bitwise __sum16;
++
+ /*
+ * Some headers seem to require this...
+ */
diff --git a/dev-libs/klibc/klibc-1.4.13.ebuild b/dev-libs/klibc/klibc-1.4.13.ebuild
index 92ba6e2e23ea..969deacb72e3 100644
--- a/dev-libs/klibc/klibc-1.4.13.ebuild
+++ b/dev-libs/klibc/klibc-1.4.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.4.13.ebuild,v 1.2 2007/01/20 10:58:43 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.4.13.ebuild,v 1.3 2007/02/09 22:31:04 phreak Exp $
inherit eutils linux-info multilib
@@ -65,8 +65,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-resumelib.patch
-
if [[ ! -d /usr/${CTARGET} ]] ; then
echo
eerror "It does not look like your cross-compiler is setup properly!"
@@ -89,13 +87,13 @@ src_unpack() {
die "Your kernel sources are not configured for your chosen arch!"
fi
- cd ${S}
+ cd "${S}"
# Add our linux source tree symlink
ln -snf ${KV_DIR} linux
# Some reason .config has outdated mtime
- touch ${S}/.config
+ touch "${S}"/.config
# We do not want all the nice prelink warnings
# NOTE: for amd64, we might change below to '/usr/$(get_libdir)/klibc',
@@ -109,13 +107,22 @@ src_unpack() {
# NOTE: Disabling this for now, as klibc have -fno-stack-protector. Will
# enable it again if there is still issues.
#epatch "${FILESDIR}/${PN}"-1.4.7-nostdinc-flags.patch
+
# Build interp.o with EXTRA_KLIBCAFLAGS (.S source)
- epatch "${FILESDIR}/${PN}"-1.4.11-interp-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.4.11-interp-flags.patch
+
+ # Fix a nasty typedef error in the sources, appearing on >= linux-2.6.19
+ # (see #165472).
+ epatch "${FILESDIR}"/${PN}-1.4.13-types.h.patch
+
+ # Fix the include in ${S}usr/kinit/resume/resumelib.c to use autoconf.h
+ # instead of config.h.
+ epatch "${FILESDIR}"/${PN}-1.4.13-resumelib.patch
# klibc detects mips64 systems as having 64bit userland
# Force them to 32bit userlands instead
if ! use n32; then
- epatch "${FILESDIR}/${PN}"-1.4.9-mips32.patch
+ epatch "${FILESDIR}"/${PN}-1.4.9-mips32.patch
fi
# Linker path is awry
@@ -170,7 +177,7 @@ src_install() {
make \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
- INSTALLROOT=${D} \
+ INSTALLROOT="${D}" \
ARCH=$(guess_arch) \
CROSS="${CTARGET}-" \
libdir="/usr/$(get_libdir)" \
@@ -186,7 +193,7 @@ src_install() {
make \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
- INSTALLROOT=${D} \
+ INSTALLROOT="${D}" \
libdir="/usr/$(get_libdir)" \
SHLIBDIR="/$(get_libdir)" \
mandir="/usr/share/man" \
@@ -203,15 +210,15 @@ src_install() {
if ! is_cross ; then
insinto /usr/share/aclocal
- doins ${FILESDIR}/klibc.m4
+ doins "${FILESDIR}"/klibc.m4
- doenvd ${S}/70klibc
+ doenvd "${S}"/70klibc
- dodoc ${S}/README ${S}/usr/klibc/{LICENSE,CAVEATS}
- newdoc ${S}/usr/klibc/README README.klibc
- newdoc ${S}/usr/klibc/arch/README README.klibc.arch
- docinto dash; newdoc ${S}/usr/dash/README.klibc README
- docinto gzip; dodoc ${S}/usr/gzip/{COPYING,README}
+ dodoc "${S}"/README "${S}"/usr/klibc/{LICENSE,CAVEATS}
+ newdoc "${S}"/usr/klibc/README README.klibc
+ newdoc "${S}"/usr/klibc/arch/README README.klibc.arch
+ docinto dash; newdoc "${S}"/usr/dash/README.klibc README
+ docinto gzip; dodoc "${S}"/usr/gzip/{COPYING,README}
fi
}