summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-27 06:55:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-27 06:55:07 +0000
commit757ca99738163fb0e098601addb47c7e56bdeaeb (patch)
tree98c419becef45f35e08c552d713ab794a1217d4d /dev-libs/libbulletml/libbulletml-0.0.6.ebuild
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-757ca99738163fb0e098601addb47c7e56bdeaeb.tar.gz
gentoo-2-757ca99738163fb0e098601addb47c7e56bdeaeb.tar.bz2
gentoo-2-757ca99738163fb0e098601addb47c7e56bdeaeb.zip
initial commit - ebuild submitted by Atzm Watanabe via bug #45038
Diffstat (limited to 'dev-libs/libbulletml/libbulletml-0.0.6.ebuild')
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
new file mode 100644
index 000000000000..4bc93f146b5e
--- /dev/null
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.1 2004/09/27 06:55:07 mr_bones_ Exp $
+
+DESCRIPTION="A Library of Bullet Markup Language"
+HOMEPAGE="http://user.ecc.u-tokyo.ac.jp/~s31552/wp/libbulletml/index_en.html"
+SRC_URI="http://user.ecc.u-tokyo.ac.jp/~s31552/wp/libbulletml/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+S="${WORKDIR}/${PN#lib}/src"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dolib.a libbulletml.a
+
+ insinto /usr/include/bulletml
+ doins *.h
+
+ insinto /usr/include/bulletml/tinyxml
+ doins tinyxml/tinyxml.h
+
+ insinto /usr/include/bulletml/ygg
+ doins ygg/ygg.h
+
+ dodoc ../README*
+}