summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-05-18 08:11:05 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-05-18 08:11:05 +0000
commit50c2d924128c1641a1cd59f365370fdad0d548ae (patch)
tree13f69ab39b818d00998af59001a7d9914758b496 /dev-libs/libburn
parentVersion bump. (diff)
downloadgentoo-2-50c2d924128c1641a1cd59f365370fdad0d548ae.tar.gz
gentoo-2-50c2d924128c1641a1cd59f365370fdad0d548ae.tar.bz2
gentoo-2-50c2d924128c1641a1cd59f365370fdad0d548ae.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux i686, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'dev-libs/libburn')
-rw-r--r--dev-libs/libburn/ChangeLog7
-rw-r--r--dev-libs/libburn/libburn-1.3.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-libs/libburn/ChangeLog b/dev-libs/libburn/ChangeLog
index 0f9d3cdecd09..0bfecdc582cd 100644
--- a/dev-libs/libburn/ChangeLog
+++ b/dev-libs/libburn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libburn
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.141 2013/04/26 09:20:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.142 2013/05/18 08:11:05 billie Exp $
+
+*libburn-1.3.0 (18 May 2013)
+
+ 18 May 2013; Daniel Pielmeier <billie@gentoo.org> +libburn-1.3.0.ebuild:
+ Version bump.
26 Apr 2013; Agostino Sarubbo <ago@gentoo.org> libburn-1.2.8.ebuild:
Stable for sparc, wrt bug #461100
diff --git a/dev-libs/libburn/libburn-1.3.0.ebuild b/dev-libs/libburn/libburn-1.3.0.ebuild
new file mode 100644
index 000000000000..6b2420133ee2
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-1.3.0.ebuild,v 1.1 2013/05/18 08:11:05 billie Exp $
+
+EAPI=5
+
+DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cdio debug static-libs track-src-odirect"
+
+RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable track-src-odirect) \
+ --enable-pkg-check-modules \
+ $(use_enable cdio libcdio) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ cd "${S}"/cdrskin
+ docinto cdrskin
+ dodoc *.txt README
+ docinto cdrskin/html
+ dohtml cdrskin_eng.html
+
+ find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}