summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-24 01:12:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-24 01:12:13 +0000
commit30945c3a30017d17e6c998ee9d408c79c65148ee (patch)
treef339fc4edea93e1ce67696dbded54921546de4b0 /dev-libs/libcdio/libcdio-0.76.ebuild
parentquote the hell out of variables and only announce the -ded script if USE=dedi... (diff)
downloadgentoo-2-30945c3a30017d17e6c998ee9d408c79c65148ee.tar.gz
gentoo-2-30945c3a30017d17e6c998ee9d408c79c65148ee.tar.bz2
gentoo-2-30945c3a30017d17e6c998ee9d408c79c65148ee.zip
New upstream version. Dropped freebsd patch, no more needed.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-libs/libcdio/libcdio-0.76.ebuild')
-rw-r--r--dev-libs/libcdio/libcdio-0.76.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libcdio/libcdio-0.76.ebuild b/dev-libs/libcdio/libcdio-0.76.ebuild
new file mode 100644
index 000000000000..55b3f969dbff
--- /dev/null
+++ b/dev-libs/libcdio/libcdio-0.76.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcdio/libcdio-0.76.ebuild,v 1.1 2005/09/24 01:12:13 flameeyes Exp $
+
+inherit libtool eutils
+
+DESCRIPTION="A library to encapsulate CD-ROM reading and control"
+HOMEPAGE="http://www.gnu.org/software/libcdio/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cddb minimal"
+
+RDEPEND="!minimal? ( dev-libs/popt )
+ cddb? ( >=media-libs/libcddb-0.9.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize --reverse-deps
+}
+
+src_compile() {
+ econf \
+ $(use_enable cddb) \
+ $(use_with !minimal cd-drive) \
+ $(use_with !minimal cd-info) \
+ $(use_with !minimal cd-paranoia) \
+ $(use_with !minimal cdda-player) \
+ $(use_with !minimal cd-read) \
+ $(use_with !minimal iso-info) \
+ $(use_with !minimal iso-read) \
+ --with-cd-paranoia-name=libcdio-paranoia \
+ --disable-vcd-info \
+ --disable-dependency-tracking || die "configure failed"
+ # had problem with parallel make (phosphan@gentoo.org)
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}