summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-12-28 14:54:54 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-12-28 14:54:54 +0000
commit4d1e857b41a7bff542a2de51c200b184a6d02dc3 (patch)
tree48c7b147ecb798ba6e878f6e9a050a6495ff7b25 /dev-libs/libdaemon
parentAdd missing keywords in accordance with dev-ruby/rubygems and dev-lang/ruby:1.9. (diff)
downloadgentoo-2-4d1e857b41a7bff542a2de51c200b184a6d02dc3.tar.gz
gentoo-2-4d1e857b41a7bff542a2de51c200b184a6d02dc3.tar.bz2
gentoo-2-4d1e857b41a7bff542a2de51c200b184a6d02dc3.zip
Remove overshadowed versions. Bump latest to eapi4. Remove libtool archive. Provide static-libs useflag.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdaemon')
-rw-r--r--dev-libs/libdaemon/ChangeLog8
-rw-r--r--dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch39
-rw-r--r--dev-libs/libdaemon/libdaemon-0.12.ebuild50
-rw-r--r--dev-libs/libdaemon/libdaemon-0.13-r1.ebuild51
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r1.ebuild35
5 files changed, 29 insertions, 154 deletions
diff --git a/dev-libs/libdaemon/ChangeLog b/dev-libs/libdaemon/ChangeLog
index fadb39104f1e..f23d253d0013 100644
--- a/dev-libs/libdaemon/ChangeLog
+++ b/dev-libs/libdaemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libdaemon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.71 2011/03/05 12:29:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/ChangeLog,v 1.72 2011/12/28 14:54:54 scarabeus Exp $
+
+ 28 Dec 2011; Tomáš Chvátal <scarabeus@gentoo.org> -libdaemon-0.12.ebuild,
+ -libdaemon-0.13-r1.ebuild, -files/libdaemon-0.13-bsd.patch,
+ libdaemon-0.14-r1.ebuild:
+ Remove overshadowed versions. Bump latest to eapi4. Remove libtool archive.
+ Provide static-libs useflag.
05 Mar 2011; Raúl Porcel <armin76@gentoo.org> libdaemon-0.14-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #355583
diff --git a/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch b/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch
deleted file mode 100644
index 8a439d52a62e..000000000000
--- a/dev-libs/libdaemon/files/libdaemon-0.13-bsd.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-commit 5b1daf072556c1fc9a00e8735fa0cdba280c2231
-Author: Diego 'Flameeyes' Pettenò <flameeyes@gmail.com>
-Date: Wed Oct 1 13:26:32 2008 +0200
-
- Fix building on OpenSolaris (without _NSIG definition).
-
- On OpenSolaris, the _NSIG macro is not defined, but NSIG is; as it's
- not possible to use NSIG under glibc (it would miss the SIGRT*
- series), define a SIGNAL_UPPER_BOUND depending on the system (and
- error out if the system lacks both NSIG and _NSIG).
-
-diff --git a/libdaemon/dfork.c b/libdaemon/dfork.c
-index f1ba7c1..6b94944 100644
---- a/libdaemon/dfork.c
-+++ b/libdaemon/dfork.c
-@@ -42,6 +42,14 @@
- #include "dnonblock.h"
- #include "dlog.h"
-
-+#if defined(_NSIG) /* On glibc NSIG does not count RT signals */
-+# define SIGNAL_UPPER_BOUND _NSIG
-+#elif defined(NSIG) /* Solaris defines just this */
-+# define SIGNAL_UPPER_BOUND NSIG
-+#else
-+# error "Unknown upper bound for signals"
-+#endif
-+
- static int _daemon_retval_pipe[2] = { -1, -1 };
-
- static int _null_open(int f, int fd) {
-@@ -665,7 +673,7 @@ int daemon_reset_sigs(int except, ...) {
- int daemon_reset_sigsv(const int except[]) {
- int sig;
-
-- for (sig = 1; sig < _NSIG; sig++) {
-+ for (sig = 1; sig < SIGNAL_UPPER_BOUND; sig++) {
- int reset = 1;
-
- switch (sig) {
diff --git a/dev-libs/libdaemon/libdaemon-0.12.ebuild b/dev-libs/libdaemon/libdaemon-0.12.ebuild
deleted file mode 100644
index d219478afc52..000000000000
--- a/dev-libs/libdaemon/libdaemon-0.12.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.12.ebuild,v 1.11 2008/11/09 12:12:07 vapier Exp $
-
-inherit libtool
-
-DESCRIPTION="Simple library for creating daemon processes in C"
-HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
-SRC_URI="http://0pointer.de/lennart/projects/libdaemon/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
-
- elibtoolize
-}
-
-src_compile() {
- econf --disable-lynx || die "econf failed"
- emake || die "emake failed"
-
- if use doc ; then
- einfo "Building documentation"
- make doxygen || die "make doxygen failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if use doc; then
- ln -sf doc/reference/html reference
- dohtml -r doc/README.html reference
- doman doc/reference/man/man*/*
- fi
-
- if use examples; then
- docinto examples
- dodoc examples/testd.c
- fi
-
- dodoc README
-}
diff --git a/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild b/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild
deleted file mode 100644
index 86e6e0df35ce..000000000000
--- a/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.13-r1.ebuild,v 1.8 2009/12/15 19:34:14 armin76 Exp $
-
-inherit libtool eutils
-
-DESCRIPTION="Simple library for creating daemon processes in C"
-HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
-SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-bsd.patch"
- elibtoolize
-}
-
-src_compile() {
- econf --disable-lynx --localstatedir=/var
- emake || die "emake failed"
-
- if use doc ; then
- einfo "Building documentation"
- make doxygen || die "make doxygen failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if use doc; then
- ln -sf doc/reference/html reference
- dohtml -r doc/README.html reference
- doman doc/reference/man/man*/*
- fi
-
- if use examples; then
- docinto examples
- dodoc examples/testd.c
- fi
-
- dodoc README
-}
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
index 59fc3070d6fa..4c42c899a840 100644
--- a/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
+++ b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild,v 1.6 2011/03/05 12:29:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild,v 1.7 2011/12/28 14:54:54 scarabeus Exp $
+
+EAPI=4
inherit libtool eutils
@@ -11,39 +13,46 @@ SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc examples"
+IUSE="doc examples static-libs"
RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
-src_compile() {
+DOCS=( "README" )
+
+src_configure() {
econf \
- --docdir=/usr/share/doc/${PF} \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
--localstatedir=/var \
--disable-examples \
- --disable-lynx
- emake || die "emake failed"
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
if use doc ; then
einfo "Building documentation"
- emake doxygen || die "make doxygen failed"
+ emake doxygen
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
if use doc; then
ln -sf doc/reference/html reference
- dohtml -r doc/README.html doc/style.css reference || die "dohtml failed"
- doman doc/reference/man/man*/* || die "doman failed"
+ dohtml -r doc/README.html doc/style.css reference
+ doman doc/reference/man/man*/*
fi
if use examples; then
docinto examples
- dodoc examples/testd.c || die "dodoc 1 failed"
+ dodoc examples/testd.c
fi
- rm -rf "${D}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
- dodoc README || die "dodoc 2 failed"
+ rm -rf "${ED}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
}