summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:38:19 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:38:19 +0000
commit39c8114cf5cf1a3585a043048aa619d2d87a075c (patch)
tree0c150bff88de6e42397bce770af021ffe58b45f4 /dev-libs/libdivsufsort
parentImport the live ebuild. (diff)
downloadgentoo-2-39c8114cf5cf1a3585a043048aa619d2d87a075c.tar.gz
gentoo-2-39c8114cf5cf1a3585a043048aa619d2d87a075c.tar.bz2
gentoo-2-39c8114cf5cf1a3585a043048aa619d2d87a075c.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-libs/libdivsufsort')
-rw-r--r--dev-libs/libdivsufsort/ChangeLog8
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild31
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-libs/libdivsufsort/ChangeLog b/dev-libs/libdivsufsort/ChangeLog
index 9cbd6b377e77..fe7f2e147aaf 100644
--- a/dev-libs/libdivsufsort/ChangeLog
+++ b/dev-libs/libdivsufsort/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-libs/libdivsufsort
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivsufsort/ChangeLog,v 1.1 2012/04/10 15:49:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivsufsort/ChangeLog,v 1.2 2012/12/15 12:38:19 mgorny Exp $
+
+*libdivsufsort-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +libdivsufsort-9999.ebuild:
+ Import the live ebuild.
*libdivsufsort-2.0.1 (10 Apr 2012)
10 Apr 2012; Michał Górny <mgorny@gentoo.org> +libdivsufsort-2.0.1.ebuild,
+metadata.xml:
Initial commit for libdivsufsort, a new dependency of zpaq.
-
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
new file mode 100644
index 000000000000..dd97b7340ae1
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild,v 1.1 2012/12/15 12:38:19 mgorny Exp $
+
+EAPI=4
+inherit cmake-utils multilib
+
+#if LIVE
+ESVN_REPO_URI="http://libdivsufsort.googlecode.com/svn/trunk/"
+inherit subversion
+#endif
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="http://code.google.com/p/libdivsufsort/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_prepare() {
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}