summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-30 04:12:51 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-30 04:12:51 +0000
commit599c4f26a167b3704fa9353d87a2c83db7875cbb (patch)
tree15887841657d93dcf010147456b883dfa8026f9c /dev-libs/libexplain
parentSkip test_integration.py to avoid bugs 486736 and 489870. (diff)
downloadgentoo-2-599c4f26a167b3704fa9353d87a2c83db7875cbb.tar.gz
gentoo-2-599c4f26a167b3704fa9353d87a2c83db7875cbb.tar.bz2
gentoo-2-599c4f26a167b3704fa9353d87a2c83db7875cbb.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/libexplain')
-rw-r--r--dev-libs/libexplain/ChangeLog7
-rw-r--r--dev-libs/libexplain/libexplain-1.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index 17b6c30be4f7..b3c42ccd32b6 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libexplain
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.25 2013/05/10 05:55:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.26 2013/11/30 04:12:51 radhermit Exp $
+
+*libexplain-1.3 (30 Nov 2013)
+
+ 30 Nov 2013; Tim Harder <radhermit@gentoo.org> +libexplain-1.3.ebuild:
+ Version bump.
*libexplain-1.2 (10 May 2013)
diff --git a/dev-libs/libexplain/libexplain-1.3.ebuild b/dev-libs/libexplain/libexplain-1.3.ebuild
new file mode 100644
index 000000000000..73cb336a8766
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.3.ebuild,v 1.1 2013/11/30 04:12:51 radhermit Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="doc static-libs"
+
+RDEPEND="
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11
+ sys-process/lsof"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.35
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+"
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}" || die
+
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile all-doc
+}