summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-04 06:46:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-04 06:46:50 +0000
commitc09d4cbc4a6b0f42cf93c2406ac5e92e6e6aca39 (patch)
treee4ecf48863e7170c552fa47efe6fb0bf69a86213 /dev-libs/libffi/libffi-3.0.11.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c09d4cbc4a6b0f42cf93c2406ac5e92e6e6aca39.tar.gz
gentoo-2-c09d4cbc4a6b0f42cf93c2406ac5e92e6e6aca39.tar.bz2
gentoo-2-c09d4cbc4a6b0f42cf93c2406ac5e92e6e6aca39.zip
Check if ${ROOT} is / or not before executing the -lffi sanity link check wrt #437046
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libffi/libffi-3.0.11.ebuild')
-rw-r--r--dev-libs/libffi/libffi-3.0.11.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-libs/libffi/libffi-3.0.11.ebuild b/dev-libs/libffi/libffi-3.0.11.ebuild
index cf6c6ca60789..e44a67f30feb 100644
--- a/dev-libs/libffi/libffi-3.0.11.ebuild
+++ b/dev-libs/libffi/libffi-3.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11.ebuild,v 1.13 2012/10/02 06:15:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.11.ebuild,v 1.14 2012/10/04 06:46:50 ssuominen Exp $
EAPI=4
@@ -26,7 +26,7 @@ DOCS="ChangeLog* README"
pkg_setup() {
# Check for orphaned libffi, see http://bugs.gentoo.org/354903 for example
- if ! has_version ${CATEGORY}/${PN}; then
+ if [[ ${ROOT} != / ]] || ! has_version ${CATEGORY}/${PN}; then
local base="${T}"/conftest
echo 'int main() { }' > "${base}".c
$(tc-getCC) -o "${base}" "${base}".c -lffi >&/dev/null