summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2008-12-24 18:31:29 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2008-12-24 18:31:29 +0000
commit8567ef421c942385f7438bc1635fad5452e5c7c3 (patch)
tree2702c748b8d9a363854df33d9c789fb2f22cd9db /dev-libs/libffi/libffi-3.0.8.ebuild
parentalpha/ia64 stable wrt #249875 (diff)
downloadgentoo-2-8567ef421c942385f7438bc1635fad5452e5c7c3.tar.gz
gentoo-2-8567ef421c942385f7438bc1635fad5452e5c7c3.tar.bz2
gentoo-2-8567ef421c942385f7438bc1635fad5452e5c7c3.zip
version bump requested by Matteo Modesti (bug #252344)
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-libs/libffi/libffi-3.0.8.ebuild')
-rw-r--r--dev-libs/libffi/libffi-3.0.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libffi/libffi-3.0.8.ebuild b/dev-libs/libffi/libffi-3.0.8.ebuild
new file mode 100644
index 000000000000..b88f688f4d7a
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.8.ebuild,v 1.1 2008/12/24 18:31:29 wormo Exp $
+
+inherit eutils
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions."
+HOMEPAGE="http://sourceware.org/libffi"
+SRC_URI="ftp://sourceware.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+DEPEND="test? ( dev-util/dejagnu )"
+RDEPEND=""
+
+pkg_setup() {
+ ewarn "This package provides a separate libffi which may conflict with the"
+ ewarn "one provided by sys-devel/gcc when it is built with libffi use flag on."
+ ebeep
+}
+
+src_compile() {
+ econf --disable-dependency-tracking \
+ $(use_enable debug) || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog* README TODO
+}