summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-10-08 01:53:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-10-08 01:53:12 +0000
commitcca7e911e9846161062e4dcc1164508cf71cd1da (patch)
treee94eeb0a888b7c6901a1df86a771a71f12b42023 /dev-libs/libg15/libg15-9999.ebuild
parentVersion bump. (diff)
downloadgentoo-2-cca7e911e9846161062e4dcc1164508cf71cd1da.tar.gz
gentoo-2-cca7e911e9846161062e4dcc1164508cf71cd1da.tar.bz2
gentoo-2-cca7e911e9846161062e4dcc1164508cf71cd1da.zip
Make a live version, since there has not been a release in years, and G510 support is only in SVN.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libg15/libg15-9999.ebuild')
-rw-r--r--dev-libs/libg15/libg15-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/libg15/libg15-9999.ebuild b/dev-libs/libg15/libg15-9999.ebuild
new file mode 100644
index 000000000000..f44a944549da
--- /dev/null
+++ b/dev-libs/libg15/libg15-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libg15/libg15-9999.ebuild,v 1.1 2012/10/08 01:53:12 robbat2 Exp $
+
+EAPI=4
+ESVN_PROJECT=g15tools/trunk
+ESVN_REPO_URI="https://g15tools.svn.sourceforge.net/svnroot/${ESVN_PROJECT}/${PN}"
+
+inherit subversion base eutils autotools
+
+DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND=${DEPEND}
+
+DOCS=( AUTHORS README ChangeLog )
+
+src_unpack() {
+ if [[ ${PV} = *9999* ]]; then
+ subversion_src_unpack
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} = *9999* ]]; then
+ subversion_wc_info
+ fi
+ base_src_prepare
+ if [[ ${PV} = *9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}