summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-12-10 21:12:46 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-12-10 21:12:46 +0000
commitc646b11d582ca30263498e93862b5b52af321162 (patch)
tree82edc9245d4c8b8f259bba1e6887251b7ea6a5ba /dev-libs/libgcrypt
parentAdd ~alpha wrt #201366 (diff)
downloadgentoo-2-c646b11d582ca30263498e93862b5b52af321162.tar.gz
gentoo-2-c646b11d582ca30263498e93862b5b52af321162.tar.bz2
gentoo-2-c646b11d582ca30263498e93862b5b52af321162.zip
Version bump
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog7
-rw-r--r--dev-libs/libgcrypt/files/digest-libgcrypt-1.4.06
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.0.ebuild72
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 63a2439787e1..2710092f556d 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgcrypt
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.98 2007/11/10 18:36:07 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.99 2007/12/10 21:12:46 alonbl Exp $
+
+*libgcrypt-1.4.0 (10 Dec 2007)
+
+ 10 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org> +libgcrypt-1.4.0.ebuild:
+ Version bump
10 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org> -libgcrypt-1.1.12.ebuild,
-libgcrypt-1.1.94.ebuild, -libgcrypt-1.2.0.ebuild,
diff --git a/dev-libs/libgcrypt/files/digest-libgcrypt-1.4.0 b/dev-libs/libgcrypt/files/digest-libgcrypt-1.4.0
new file mode 100644
index 000000000000..4b7e3e838700
--- /dev/null
+++ b/dev-libs/libgcrypt/files/digest-libgcrypt-1.4.0
@@ -0,0 +1,6 @@
+MD5 9f33d63e2c3fc697dad370b02b858a44 libgcrypt-1.4.0-idea.diff.bz2 2944
+RMD160 4044cc244ca375a832674561cf030840c239ee86 libgcrypt-1.4.0-idea.diff.bz2 2944
+SHA256 56bc3da6e8477f2cc3ce3186c175442124d4c5f5c7078704765b33cc944340d3 libgcrypt-1.4.0-idea.diff.bz2 2944
+MD5 b013f798a1088afb07336bce5a9c24c5 libgcrypt-1.4.0.tar.bz2 964779
+RMD160 bccec927cdf0437778d8aa1071b27a871ed5c72d libgcrypt-1.4.0.tar.bz2 964779
+SHA256 d7f855f766944a5b6e7ffee2d6ffdf828ab709acd4453b0e64aea808ce2760ec libgcrypt-1.4.0.tar.bz2 964779
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.0.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.0.ebuild
new file mode 100644
index 000000000000..19cd6457dc36
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.0.ebuild,v 1.1 2007/12/10 21:12:46 alonbl Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.bz2
+ !bindist? ( idea? ( mirror://gentoo/${P}-idea.diff.bz2 ) )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls bindist idea"
+
+RDEPEND="nls? ( virtual/libintl )
+ >=dev-libs/libgpg-error-1.0"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use idea; then
+ if use bindist; then
+ elog "Skipping IDEA support to comply with binary distribution (bug #148907)."
+ else
+ ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html"
+ epatch "${WORKDIR}/${P}-idea.diff"
+ AT_M4DIR="m4" eautoreconf
+ fi
+ fi
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --with-pic \
+ --enable-noexecstack \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+}
+
+pkg_postinst() {
+ if use !bindist && use idea; then
+ ewarn "-----------------------------------------------------------------------------------"
+ ewarn "IDEA"
+ ewarn "you have compiled ${PN} with support for the IDEA algorithm, this code"
+ ewarn "is distributed under the GPL in countries where it is permitted to do so"
+ ewarn "by law."
+ ewarn
+ ewarn "Please read http://www.gnupg.org/(en)/faq/why-not-idea.html for more information."
+ ewarn
+ ewarn "If you are in a country where the IDEA algorithm is patented, you are permitted"
+ ewarn "to use it at no cost for 'non revenue generating data transfer between private"
+ ewarn "individuals'."
+ ewarn
+ ewarn "Countries where the patent applies are listed here"
+ ewarn "http://www.mediacrypt.com/_contents/10_idea/101030_ea_pi.asp"
+ ewarn
+ ewarn "Further information and other licenses are availble from http://www.mediacrypt.com/"
+ ewarn "-----------------------------------------------------------------------------------"
+ fi
+}