summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-22 13:43:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-09-22 13:43:15 +0000
commitf3365ea6810059cd42c9e69bd360e8d7fe3811d0 (patch)
tree770b22989deb5b8eee436d39dcae432729263524 /dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-f3365ea6810059cd42c9e69bd360e8d7fe3811d0.tar.gz
gentoo-2-f3365ea6810059cd42c9e69bd360e8d7fe3811d0.tar.bz2
gentoo-2-f3365ea6810059cd42c9e69bd360e8d7fe3811d0.zip
Revbump: patch gpg-error-config to not provide -L options to system library paths (submitted upstream, closes bug #383863); use EAPI=4 and its features; avoid installing-and-removing the common-lisp code; remove .la file since the library has no dependencies.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild')
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild b/dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild
new file mode 100644
index 000000000000..f483e630e0e1
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgpg-error/libgpg-error-1.10-r1.ebuild,v 1.1 2011/09/22 13:43:15 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils libtool
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="http://www.gnupg.org/related_software/libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp nls static-libs"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-multilib-syspaths.patch
+ epunt_cxx
+ elibtoolize
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable common-libs languages)
+}
+
+src_install() {
+ default
+
+ # library has no dependencies, so it does not need the .la file
+ find "${D}" -name '*.la' -delete
+}