summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-07 14:34:54 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-07 14:34:54 +0000
commit03a01daa8b47ce388555e1b7cdd0c5832c28800c (patch)
treecb430dd36a1f2e6ce4712398378e90b74a65ac95 /dev-libs/libgusb
parentapp-backup/deja-dup: Add missing eclass phase functions calls (diff)
downloadgentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.tar.gz
gentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.tar.bz2
gentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.zip
Version bump, drop old.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libgusb')
-rw-r--r--dev-libs/libgusb/ChangeLog8
-rw-r--r--dev-libs/libgusb/libgusb-0.1.3.ebuild37
-rw-r--r--dev-libs/libgusb/libgusb-0.1.6.ebuild48
3 files changed, 55 insertions, 38 deletions
diff --git a/dev-libs/libgusb/ChangeLog b/dev-libs/libgusb/ChangeLog
index 4da4715868ce..d057a73c4e7e 100644
--- a/dev-libs/libgusb/ChangeLog
+++ b/dev-libs/libgusb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgusb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgusb/ChangeLog,v 1.33 2013/03/28 15:51:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgusb/ChangeLog,v 1.34 2013/04/07 14:34:54 pacho Exp $
+
+*libgusb-0.1.6 (07 Apr 2013)
+
+ 07 Apr 2013; Pacho Ramos <pacho@gentoo.org> +libgusb-0.1.6.ebuild,
+ -libgusb-0.1.3.ebuild:
+ Version bump, drop old.
28 Mar 2013; Agostino Sarubbo <ago@gentoo.org> libgusb-0.1.4.ebuild:
Stable for arm, wrt bug #458984
diff --git a/dev-libs/libgusb/libgusb-0.1.3.ebuild b/dev-libs/libgusb/libgusb-0.1.3.ebuild
deleted file mode 100644
index 7b3c0f3ccbda..000000000000
--- a/dev-libs/libgusb/libgusb-0.1.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgusb/libgusb-0.1.3.ebuild,v 1.15 2012/11/28 17:56:18 ssuominen Exp $
-
-EAPI=4
-
-DESCRIPTION="GObject wrapper for libusb"
-HOMEPAGE="https://gitorious.org/gusb/"
-SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~mips ppc ppc64 x86"
-IUSE="static-libs"
-
-# udev is effectively a required dependency: configuring with --disable-gudev
-# causes build failures
-RDEPEND=">=dev-libs/glib-2.28
- virtual/libusb:1
- virtual/udev[gudev]"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- dev-libs/libxslt
- virtual/pkgconfig"
-# eautoreconf requires dev-util/gtk-doc-am
-
-# Tests try to access usb devices in /dev
-RESTRICT="test"
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- rm -f "${ED}"usr/lib*/${PN}.la
-}
diff --git a/dev-libs/libgusb/libgusb-0.1.6.ebuild b/dev-libs/libgusb/libgusb-0.1.6.ebuild
new file mode 100644
index 000000000000..11df3f165a5c
--- /dev/null
+++ b/dev-libs/libgusb/libgusb-0.1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgusb/libgusb-0.1.6.ebuild,v 1.1 2013/04/07 14:34:54 pacho Exp $
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils vala
+
+DESCRIPTION="GObject wrapper for libusb"
+HOMEPAGE="https://gitorious.org/gusb/"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection static-libs vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# udev is effectively a required dependency: configuring with --disable-gudev
+# causes build failures
+RDEPEND=">=dev-libs/glib-2.28:2
+ virtual/libusb:1
+ virtual/udev[gudev]
+ introspection? ( >=dev-libs/gobject-introspection-1.29 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+# gtk-doc-am needed for proper api docs installation
+
+# Tests try to access usb devices in /dev
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable vala)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}