summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-21 22:20:24 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-21 22:20:24 +0000
commit9118d55f1dc0e00f009a50767a87535087e6e58f (patch)
tree129c592ad28177d315b1650977b5cab024d98a1e /dev-libs/libiconv
parentx86 stable, security bug #209148 (diff)
downloadgentoo-2-9118d55f1dc0e00f009a50767a87535087e6e58f.tar.gz
gentoo-2-9118d55f1dc0e00f009a50767a87535087e6e58f.tar.bz2
gentoo-2-9118d55f1dc0e00f009a50767a87535087e6e58f.zip
Version bump -- needs iconv rpath fixed though.
(Portage version: 2.2_pre2)
Diffstat (limited to 'dev-libs/libiconv')
-rw-r--r--dev-libs/libiconv/ChangeLog9
-rw-r--r--dev-libs/libiconv/libiconv-1.12.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-libs/libiconv/ChangeLog b/dev-libs/libiconv/ChangeLog
index b7dc2687a1e0..a800573463a1 100644
--- a/dev-libs/libiconv/ChangeLog
+++ b/dev-libs/libiconv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libiconv
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.28 2007/01/23 07:17:54 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/ChangeLog,v 1.29 2008/02/21 22:20:24 vapier Exp $
+
+*libiconv-1.12 (21 Feb 2008)
+
+ 21 Feb 2008; Mike Frysinger <vapier@gentoo.org> +libiconv-1.12.ebuild:
+ Version bump -- needs iconv rpath fixed though.
23 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> libiconv-1.11.ebuild:
Use toolchain-funcs's gen_usr_ldscript. See bug #144529.
diff --git a/dev-libs/libiconv/libiconv-1.12.ebuild b/dev-libs/libiconv/libiconv-1.12.ebuild
new file mode 100644
index 000000000000..e3128fda75eb
--- /dev/null
+++ b/dev-libs/libiconv/libiconv-1.12.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libiconv/libiconv-1.12.ebuild,v 1.1 2008/02/21 22:20:24 vapier Exp $
+
+inherit eutils multilib flag-o-matic libtool toolchain-funcs
+
+DESCRIPTION="GNU charset conversion library for libc which doesn't implement it"
+HOMEPAGE="http://www.gnu.org/software/libiconv/"
+SRC_URI="mirror://gnu/libiconv/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+#KEYWORDS="~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="!sys-libs/glibc
+ !sys-apps/man-pages"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # This patch is needed as libiconv 1.10 provides (and uses) new functions
+ # and they are not present in the old libiconv.so, and this breaks the
+ # ${DESTDIR} != ${prefix} that we use. It's a problem for Solaris, but we
+ # don't have to deal with it for now.
+ #epatch "${FILESDIR}"/${PN}-1.10-link.patch
+
+ # Make sure that libtool support is updated to link "the linux way" on
+ # FreeBSD.
+ elibtoolize
+}
+
+src_compile() {
+ # Install in /lib as utils installed in /lib like gnutar
+ # can depend on this
+
+ # Disable NLS support because that creates a circular dependency
+ # between libiconv and gettext
+
+ econf \
+ --disable-nls \
+ --enable-shared \
+ --enable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install || die "make install failed"
+
+ # Move static libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}/$(get_libdir)" || die
+ gen_usr_ldscript libiconv.so
+ gen_usr_ldscript libcharset.so
+}