summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-11 12:20:52 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-11 12:20:52 +0000
commit6ffe2e20daa477ee17e1d29e5769a2882afd18f4 (patch)
tree9654cf6f4e41f95913b3cb1c91da6dfb0e3fb149 /dev-libs/libmateweather
parentInstall to /usr/lib/udisks instead of /usr/libexec wrt #507342 by Albert W. H... (diff)
downloadgentoo-2-6ffe2e20daa477ee17e1d29e5769a2882afd18f4.tar.gz
gentoo-2-6ffe2e20daa477ee17e1d29e5769a2882afd18f4.tar.bz2
gentoo-2-6ffe2e20daa477ee17e1d29e5769a2882afd18f4.zip
Version bump to 1.8.0.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-libs/libmateweather')
-rw-r--r--dev-libs/libmateweather/ChangeLog7
-rw-r--r--dev-libs/libmateweather/libmateweather-1.8.0.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-libs/libmateweather/ChangeLog b/dev-libs/libmateweather/ChangeLog
index 4ba72ad28738..ae9e0454b295 100644
--- a/dev-libs/libmateweather/ChangeLog
+++ b/dev-libs/libmateweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libmateweather
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmateweather/ChangeLog,v 1.4 2014/03/10 23:02:10 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmateweather/ChangeLog,v 1.5 2014/04/11 12:20:52 tomwij Exp $
+
+*libmateweather-1.8.0 (11 Apr 2014)
+
+ 11 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +libmateweather-1.8.0.ebuild:
+ Version bump to 1.8.0.
10 Mar 2014; Tom Wijsman <TomWij@gentoo.org> libmateweather-1.6.2.ebuild:
Update dependencies per the consensus formed with ssuominen.
diff --git a/dev-libs/libmateweather/libmateweather-1.8.0.ebuild b/dev-libs/libmateweather/libmateweather-1.8.0.ebuild
new file mode 100644
index 000000000000..71ecb139dc6f
--- /dev/null
+++ b/dev-libs/libmateweather/libmateweather-1.8.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmateweather/libmateweather-1.8.0.ebuild,v 1.1 2014/04/11 12:20:52 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit autotools gnome2 python-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="MATE library to access weather information from online services"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/glib-2.13:2[${PYTHON_USEDEP}]
+ >=dev-libs/libxml2-2.6:2
+ >=net-libs/libsoup-2.34:2.4
+ >=sys-libs/timezone-data-2010k:0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.11:2
+ virtual/libintl:0
+
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2:2[${PYTHON_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40.3:*
+ >=mate-base/mate-common-1.6:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ # Fix undefined use of MKDIR_P in python/Makefile.am.
+ epatch "${FILESDIR}"/${PN}-1.6.1-fix-mkdirp.patch
+ eautoreconf
+
+ python_copy_sources
+ python_foreach_impl run_in_build_dir gnome2_src_prepare
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ --enable-locations-compression \
+ --disable-all-translations-in-one-xml \
+ $(use_enable python)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+}