summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-11-04 09:44:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-11-04 09:44:28 +0000
commit03b80f1417bdabdb077a204586795662b1ca2a56 (patch)
tree14835441a662adc5358b6f93a77e2ed161b27b6f /dev-libs/libotf
parentFix compilation of python module, fix support for zlib (diff)
downloadgentoo-2-03b80f1417bdabdb077a204586795662b1ca2a56.tar.gz
gentoo-2-03b80f1417bdabdb077a204586795662b1ca2a56.tar.bz2
gentoo-2-03b80f1417bdabdb077a204586795662b1ca2a56.zip
Version bumped, bug #341911. Removed old versions.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libotf')
-rw-r--r--dev-libs/libotf/ChangeLog10
-rw-r--r--dev-libs/libotf/libotf-0.9.12.ebuild39
-rw-r--r--dev-libs/libotf/libotf-0.9.6.ebuild55
-rw-r--r--dev-libs/libotf/libotf-0.9.7.ebuild55
4 files changed, 47 insertions, 112 deletions
diff --git a/dev-libs/libotf/ChangeLog b/dev-libs/libotf/ChangeLog
index 059f6ec32b51..74571637747c 100644
--- a/dev-libs/libotf/ChangeLog
+++ b/dev-libs/libotf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libotf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.48 2009/07/22 15:17:22 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/ChangeLog,v 1.49 2010/11/04 09:44:28 matsuu Exp $
+
+*libotf-0.9.12 (04 Nov 2010)
+
+ 04 Nov 2010; MATSUU Takuto <matsuu@gentoo.org> -libotf-0.9.6.ebuild,
+ -libotf-0.9.7.ebuild, +libotf-0.9.12.ebuild:
+ Version bumped, bug #341911. Removed old versions.
22 Jul 2009; Raúl Porcel <armin76@gentoo.org> libotf-0.9.8.ebuild:
arm/sh/sparc stable wrt #271253
diff --git a/dev-libs/libotf/libotf-0.9.12.ebuild b/dev-libs/libotf/libotf-0.9.12.ebuild
new file mode 100644
index 000000000000..ac4b6c258546
--- /dev/null
+++ b/dev-libs/libotf/libotf-0.9.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.12.ebuild,v 1.1 2010/11/04 09:44:28 matsuu Exp $
+
+inherit autotools
+
+DESCRIPTION="Library for handling OpenType fonts (OTF)"
+HOMEPAGE="http://www.m17n.org/libotf/"
+SRC_URI="http://www.m17n.org/libotf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="X"
+
+RDEPEND=">=media-libs/freetype-2.1
+ X? (
+ x11-libs/libXaw
+ x11-libs/libICE
+ )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use X ; then
+ sed -i -e '/^bin_PROGRAMS/s/otfview//' example/Makefile.am || die
+ eautoreconf
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS README ChangeLog
+}
diff --git a/dev-libs/libotf/libotf-0.9.6.ebuild b/dev-libs/libotf/libotf-0.9.6.ebuild
deleted file mode 100644
index 1a3232c3d082..000000000000
--- a/dev-libs/libotf/libotf-0.9.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.6.ebuild,v 1.9 2008/06/15 06:34:03 zmedico Exp $
-
-WANT_AUTOMAKE=latest
-WANT_AUTOCONF=latest
-
-inherit autotools
-
-DESCRIPTION="Library for handling OpenType fonts (OTF)"
-HOMEPAGE="http://www.m17n.org/libotf/"
-SRC_URI="http://www.m17n.org/libotf/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE="X"
-
-RDEPEND=">=media-libs/freetype-2.1
- X? (
- x11-libs/libXaw
- x11-libs/libICE
- )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use X || sed -i -e '/^bin_PROGRAMS/s/otfview//' example/Makefile.am || die
- eautomake
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS NEWS README ChangeLog
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.9.3"
- previous_less_than_0_9_3=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_9_3 = 0 ]] ; then
- ewarn
- ewarn "Shared library extension has been changed. You may need to recompile"
- ewarn "everything depending on this library (in short, please remerge m17n-lib"
- ewarn " if you are upgrading)."
- ewarn
- fi
-}
diff --git a/dev-libs/libotf/libotf-0.9.7.ebuild b/dev-libs/libotf/libotf-0.9.7.ebuild
deleted file mode 100644
index dcdfa5cd7739..000000000000
--- a/dev-libs/libotf/libotf-0.9.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libotf/libotf-0.9.7.ebuild,v 1.4 2008/06/15 06:34:03 zmedico Exp $
-
-WANT_AUTOMAKE=latest
-WANT_AUTOCONF=latest
-
-inherit autotools
-
-DESCRIPTION="Library for handling OpenType fonts (OTF)"
-HOMEPAGE="http://www.m17n.org/libotf/"
-SRC_URI="http://www.m17n.org/libotf/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="X"
-
-RDEPEND=">=media-libs/freetype-2.1
- X? (
- x11-libs/libXaw
- x11-libs/libICE
- )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use X || sed -i -e '/^bin_PROGRAMS/s/otfview//' example/Makefile.am || die
- eautomake
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS NEWS README ChangeLog
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-0.9.3"
- previous_less_than_0_9_3=$?
-}
-
-pkg_postinst() {
- if [[ $previous_less_than_0_9_3 = 0 ]] ; then
- ewarn
- ewarn "Shared library extension has been changed. You may need to recompile"
- ewarn "everything depending on this library (in short, please remerge m17n-lib"
- ewarn " if you are upgrading)."
- ewarn
- fi
-}