summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-05-03 10:37:55 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-05-03 10:37:55 +0000
commita0a93fe48d0d8449e245ba561dc724a53dce9501 (patch)
treea3dd00efbc00f0233d7be87d8058e99d2cff199c /dev-libs/libpqxx
parentUpdate tests handling (diff)
downloadgentoo-2-a0a93fe48d0d8449e245ba561dc724a53dce9501.tar.gz
gentoo-2-a0a93fe48d0d8449e245ba561dc724a53dce9501.tar.bz2
gentoo-2-a0a93fe48d0d8449e245ba561dc724a53dce9501.zip
Inherit python-any-r1 to pull in a Python 2 interpreter. Use sed to fix
shebangs to call python2 instead of python which could be set to a Python 3 interpreter. Fixes bug 455282. (Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/ChangeLog7
-rw-r--r--dev-libs/libpqxx/libpqxx-4.0.1.ebuild17
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-libs/libpqxx/ChangeLog b/dev-libs/libpqxx/ChangeLog
index 2fe911a9273e..27f51963f218 100644
--- a/dev-libs/libpqxx/ChangeLog
+++ b/dev-libs/libpqxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpqxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.89 2013/02/02 07:58:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.90 2013/05/03 10:37:55 titanofold Exp $
+
+ 03 May 2013; Aaron W. Swenson <titanofold@gentoo.org> libpqxx-4.0.1.ebuild:
+ Inherit python-any-r1 to pull in a Python 2 interpreter. Use sed to fix
+ shebangs to call python2 instead of python which could be set to a
+ Python 3 interpreter. Fixes bug 455282.
*libpqxx-4.0.1 (02 Feb 2013)
diff --git a/dev-libs/libpqxx/libpqxx-4.0.1.ebuild b/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
index 7a08d40d7452..43b56c14efc8 100644
--- a/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
+++ b/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-4.0.1.ebuild,v 1.1 2013/02/02 07:58:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-4.0.1.ebuild,v 1.2 2013/05/03 10:37:55 titanofold Exp $
EAPI="4"
-inherit eutils
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit python-any-r1
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
@@ -15,8 +16,16 @@ LICENSE="BSD"
SLOT="0"
IUSE="doc static-libs"
-DEPEND="dev-db/postgresql-base"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-db/postgresql-base"
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed -e 's/python/python2/' \
+ -i tools/{splitconfig,template2mak.py} \
+ || die "Couldn't fix Python shebangs"
+}
src_configure() {
if use static-libs ; then