summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 07:58:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 07:58:25 +0000
commita30614873afd13b4ed0c97e305ecb02ddfeac47c (patch)
tree932187def25ba41dc7a18a84fa58797b01e97917 /dev-libs/libpqxx
parentvirtual/cblas: Drop atlas from deps (diff)
downloadgentoo-2-a30614873afd13b4ed0c97e305ecb02ddfeac47c.tar.gz
gentoo-2-a30614873afd13b4ed0c97e305ecb02ddfeac47c.tar.bz2
gentoo-2-a30614873afd13b4ed0c97e305ecb02ddfeac47c.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/ChangeLog10
-rw-r--r--dev-libs/libpqxx/libpqxx-4.0.1.ebuild76
2 files changed, 83 insertions, 3 deletions
diff --git a/dev-libs/libpqxx/ChangeLog b/dev-libs/libpqxx/ChangeLog
index e9526edebc98..2fe911a9273e 100644
--- a/dev-libs/libpqxx/ChangeLog
+++ b/dev-libs/libpqxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libpqxx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.88 2012/12/08 18:24:07 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/ChangeLog,v 1.89 2013/02/02 07:58:25 patrick Exp $
+
+*libpqxx-4.0.1 (02 Feb 2013)
+
+ 02 Feb 2013; Patrick Lauer <patrick@gentoo.org> +libpqxx-4.0.1.ebuild:
+ Bump
08 Dec 2012; Jeroen Roovers <jer@gentoo.org> libpqxx-4.0-r1.ebuild:
Stable for HPPA (bug #396483).
@@ -334,4 +339,3 @@
06 Jun 2003; Masatomo Nakano <nakano@gentoo.org> libpqxx-1.5.1.ebuild:
Initial import. Thanks to Andy Pyles <a_pyles@yahoo.com>.
-
diff --git a/dev-libs/libpqxx/libpqxx-4.0.1.ebuild b/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
new file mode 100644
index 000000000000..7a08d40d7452
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpqxx/libpqxx-4.0.1.ebuild,v 1.1 2013/02/02 07:58:25 patrick Exp $
+
+EAPI="4"
+
+inherit eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="C++ client API for PostgreSQL. The standard front-end for writing C++ programs that use PostgreSQL."
+SRC_URI="http://pqxx.org/download/software/${PN}/${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc static-libs"
+
+DEPEND="dev-db/postgresql-base"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use static-libs ; then
+ econf --enable-static
+ else
+ econf --enable-shared
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS README*
+ use doc && dohtml -r doc/html/*
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${EROOT%/}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
+ source "${EROOT%/}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ # Currently works with highest server version in tree
+ #server_version=$(echo ${server_version} | cut -d " " -f 2 | cut -d "." -f -2 | tr -d .)
+ #if [[ $server_version < 92 ]] ; then
+ cd "${S}/test"
+ emake check
+ #else
+ # eerror "Server version must be 8.4.x or below."
+ # die "Server version isn't 8.4.x or below"
+ #fi
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}