summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-08-16 08:33:44 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-08-16 08:33:44 +0000
commit9889fcec6889bb28391e4f5ebc136832300b8402 (patch)
tree83bfae97ff4432f5cde5822cd129eb055a5c1924 /dev-libs/librelp
parentBump (diff)
downloadgentoo-2-9889fcec6889bb28391e4f5ebc136832300b8402.tar.gz
gentoo-2-9889fcec6889bb28391e4f5ebc136832300b8402.tar.bz2
gentoo-2-9889fcec6889bb28391e4f5ebc136832300b8402.zip
version bump, fix #481222
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs/librelp')
-rw-r--r--dev-libs/librelp/ChangeLog9
-rw-r--r--dev-libs/librelp/librelp-1.1.5.ebuild27
-rw-r--r--dev-libs/librelp/librelp-1.2.0.ebuild27
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-libs/librelp/ChangeLog b/dev-libs/librelp/ChangeLog
index fdc8dccaa078..b7a235af8b1a 100644
--- a/dev-libs/librelp/ChangeLog
+++ b/dev-libs/librelp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/librelp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/ChangeLog,v 1.20 2013/06/27 18:09:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/ChangeLog,v 1.21 2013/08/16 08:33:44 ultrabug Exp $
+
+*librelp-1.2.0 (16 Aug 2013)
+*librelp-1.1.5 (16 Aug 2013)
+
+ 16 Aug 2013; Ultrabug <ultrabug@gentoo.org> +librelp-1.1.5.ebuild,
+ +librelp-1.2.0.ebuild:
+ version bump, fix #481222
27 Jun 2013; Agostino Sarubbo <ago@gentoo.org> librelp-1.0.1.ebuild:
Stable for x86, wrt bug #472564
diff --git a/dev-libs/librelp/librelp-1.1.5.ebuild b/dev-libs/librelp/librelp-1.1.5.ebuild
new file mode 100644
index 000000000000..fcd6969fe133
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/librelp-1.1.5.ebuild,v 1.1 2013/08/16 08:33:44 ultrabug Exp $
+
+EAPI="5"
+
+DESCRIPTION="An easy to use library for the RELP protocol."
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+ use doc && dohtml doc/relp.html
+}
diff --git a/dev-libs/librelp/librelp-1.2.0.ebuild b/dev-libs/librelp/librelp-1.2.0.ebuild
new file mode 100644
index 000000000000..d3e8c13548eb
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librelp/librelp-1.2.0.ebuild,v 1.1 2013/08/16 08:33:44 ultrabug Exp $
+
+EAPI="5"
+
+DESCRIPTION="An easy to use library for the RELP protocol."
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 doc? ( FDL-1.3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog
+ use doc && dohtml doc/relp.html
+}