summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-03-08 20:06:35 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-03-08 20:06:35 +0000
commit561f7219c3bc7a79c30c931003f6c47e190ea08d (patch)
tree58f405652e504251f682bb5896337f38541a650a /dev-libs/librep
parentDrop KDE 4.2.0 (diff)
downloadgentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.tar.gz
gentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.tar.bz2
gentoo-2-561f7219c3bc7a79c30c931003f6c47e190ea08d.zip
Version bumps
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/ChangeLog10
-rw-r--r--dev-libs/librep/files/librep-0.17.3-disable-elisp.patch19
-rw-r--r--dev-libs/librep/librep-0.17.3.ebuild61
3 files changed, 88 insertions, 2 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index a39013575ded..d4fc4711a453 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/librep
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.52 2008/10/12 12:25:49 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.53 2009/03/08 20:06:34 truedfx Exp $
+
+*librep-0.17.3 (05 Mar 2009)
+
+ 05 Mar 2009; Harald van Dijk <truedfx@gentoo.org>
+ +files/librep-0.17.3-disable-elisp.patch, +librep-0.17.3.ebuild:
+ Version bump
12 Oct 2008; Ulrich Mueller <ulm@gentoo.org> librep-0.17_p20070101.ebuild:
Specify name of Emacs site-init file explicitely.
diff --git a/dev-libs/librep/files/librep-0.17.3-disable-elisp.patch b/dev-libs/librep/files/librep-0.17.3-disable-elisp.patch
new file mode 100644
index 000000000000..ebe7aff90a4f
--- /dev/null
+++ b/dev-libs/librep/files/librep-0.17.3-disable-elisp.patch
@@ -0,0 +1,19 @@
+--- librep-0.17.3/Makefile.in
++++ librep-0.17.3/Makefile.in
+@@ -53,15 +53,13 @@
+ $(INSTALL_SCRIPT) libtool $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_DATA) rules.mk $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_SCRIPT) install-aliases $(DESTDIR)$(repcommonexecdir)
+- $(INSTALL_DATA) rep-debugger.el $(DESTDIR)$(emacssitelispdir)
+ mkdir -p $(DESTDIR)$(libdir)/pkgconfig
+ $(INSTALL_DATA) $(top_srcdir)/librep.pc $(DESTDIR)$(libdir)/pkgconfig/
+
+ installdirs : mkinstalldirs
+ $(SHELL) $< $(DESTDIR)$(repdir)/$(version) \
+ $(DESTDIR)$(bindir) $(DESTDIR)$(aclocaldir) \
+- $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir) \
++ $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir)
+- $(DESTDIR)$(emacssitelispdir)
+
+ uninstall :
+ -for dir in $(INSTALL_SUBDIRS); do \
diff --git a/dev-libs/librep/librep-0.17.3.ebuild b/dev-libs/librep/librep-0.17.3.ebuild
new file mode 100644
index 000000000000..b5326bf1b3b5
--- /dev/null
+++ b/dev-libs/librep/librep-0.17.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17.3.ebuild,v 1.1 2009/03/08 20:06:34 truedfx Exp $
+
+inherit eutils multilib elisp-common
+
+DESCRIPTION="Shared library implementing a Lisp dialect"
+HOMEPAGE="http://librep.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs readline"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-disable-elisp.patch
+}
+
+src_compile() {
+ econf \
+ --libexecdir=/usr/$(get_libdir) \
+ --without-gmp \
+ --without-ffi \
+ $(use_with readline) || die "configure failed"
+
+ emake || die "make failed"
+
+ if use emacs; then
+ elisp-compile rep-debugger.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO TREE
+ docinto doc
+ dodoc doc/*
+
+ if use emacs; then
+ elisp-install ${PN} rep-debugger.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" \
+ || die "elisp-site-file-install failed"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}