summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-07-04 04:31:09 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-07-04 04:31:09 +0000
commit94dd6a926b39246b5a480565128c43029b07e29d (patch)
treee832cf31a97a7418926981faa32259a1bce27f93 /dev-libs/libsigsegv/libsigsegv-2.1.ebuild
parentForgot to disable debug USE flag, see bug #50701 (Manifest recommit) (diff)
downloadgentoo-2-94dd6a926b39246b5a480565128c43029b07e29d.tar.gz
gentoo-2-94dd6a926b39246b5a480565128c43029b07e29d.tar.bz2
gentoo-2-94dd6a926b39246b5a480565128c43029b07e29d.zip
*** empty log message ***
Diffstat (limited to 'dev-libs/libsigsegv/libsigsegv-2.1.ebuild')
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/libsigsegv-2.1.ebuild b/dev-libs/libsigsegv/libsigsegv-2.1.ebuild
new file mode 100644
index 000000000000..cf5b7474973c
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigsegv/libsigsegv-2.1.ebuild,v 1.1 2004/07/04 04:31:09 mkennedy Exp $
+
+DESCRIPTION="GNU libsigsegv is a library for handling page faults in user mode."
+HOMEPAGE="ftp://ftp.gnu.org/pub/gnu/libsigsegv/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/libsigsegv/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog* INSTALL NEWS PORTING README*
+}