summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-09-10 22:41:17 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-09-10 22:41:17 +0000
commit8e9e73f2cf9cd77eedaef0186aaac47d9ea13e42 (patch)
tree81ed85675c41396d04fecd7ce1a8cd0619a71594 /dev-libs/libsodium
parentInitial version. Added also modifications from hasufell. (diff)
downloadgentoo-2-8e9e73f2cf9cd77eedaef0186aaac47d9ea13e42.tar.gz
gentoo-2-8e9e73f2cf9cd77eedaef0186aaac47d9ea13e42.tar.bz2
gentoo-2-8e9e73f2cf9cd77eedaef0186aaac47d9ea13e42.zip
use http for better compatibility, improve style and indenting
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs/libsodium')
-rw-r--r--dev-libs/libsodium/ChangeLog6
-rw-r--r--dev-libs/libsodium/libsodium-0.4.3.ebuild12
-rw-r--r--dev-libs/libsodium/metadata.xml12
3 files changed, 17 insertions, 13 deletions
diff --git a/dev-libs/libsodium/ChangeLog b/dev-libs/libsodium/ChangeLog
index c4299672a8c5..74c92dc3a770 100644
--- a/dev-libs/libsodium/ChangeLog
+++ b/dev-libs/libsodium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libsodium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/ChangeLog,v 1.1 2013/09/10 22:37:07 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/ChangeLog,v 1.2 2013/09/10 22:41:17 hasufell Exp $
+
+ 10 Sep 2013; Julian Ospald <hasufell@gentoo.org> libsodium-0.4.3.ebuild,
+ metadata.xml:
+ use http for better compatibility, improve style and indenting
*libsodium-0.4.3 (10 Sep 2013)
diff --git a/dev-libs/libsodium/libsodium-0.4.3.ebuild b/dev-libs/libsodium/libsodium-0.4.3.ebuild
index c602c409384d..5140cdc61be9 100644
--- a/dev-libs/libsodium/libsodium-0.4.3.ebuild
+++ b/dev-libs/libsodium/libsodium-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/libsodium-0.4.3.ebuild,v 1.1 2013/09/10 22:37:07 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/libsodium-0.4.3.ebuild,v 1.2 2013/09/10 22:41:17 hasufell Exp $
EAPI=5
@@ -8,7 +8,7 @@ inherit eutils
DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
HOMEPAGE="https://github.com/jedisct1/libsodium"
-SRC_URI="https://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+SRC_URI="http://download.libsodium.org/${PN}/releases/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
@@ -16,10 +16,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="+asm static-libs +urandom"
src_configure() {
- econf \
- $(use_enable asm) \
- $(use_enable !urandom blocking-random) \
- $(use_enable static-libs static)
+ econf \
+ $(use_enable asm) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static)
}
src_install() {
diff --git a/dev-libs/libsodium/metadata.xml b/dev-libs/libsodium/metadata.xml
index 5933491f98b7..fe6c42ac5bf0 100644
--- a/dev-libs/libsodium/metadata.xml
+++ b/dev-libs/libsodium/metadata.xml
@@ -5,13 +5,13 @@
<email>mrueg@gentoo.org</email>
<name>Manuel Rüger</name>
</maintainer>
-
<longdescription>
- NaCl (pronounced "salt") is a new easy-to-use high-speed software library for
- network communication, encryption, decryption, signatures, etc. NaCl's goal
- is to provide all of the core operations needed to build higher-level
- cryptographic tools. Sodium is a portable, cross-compilable, installable,
- packageable fork of NaCl, with a compatible API.
+ NaCl (pronounced "salt") is a new easy-to-use high-speed software
+ library for network communication, encryption, decryption,
+ signatures, etc. NaCl's goal is to provide all of the core
+ operations needed to build higher-level cryptographic tools.
+ Sodium is a portable, cross-compilable, installable,
+ packageable fork of NaCl, with a compatible API.
</longdescription>
<use>
<flag name="asm">Enables assembly implementations</flag>