summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-10 22:37:07 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-10 22:37:07 +0000
commitb2035a10e6af1f88ba275283cf9654e1621eb3a5 (patch)
treef390e78dd909163f8b01dc1fb113f19a2e057752 /dev-libs/libsodium
parentInitial version thanks to Chuck Seyboldt <seyboldt@gmail.com> (diff)
downloadgentoo-2-b2035a10e6af1f88ba275283cf9654e1621eb3a5.tar.gz
gentoo-2-b2035a10e6af1f88ba275283cf9654e1621eb3a5.tar.bz2
gentoo-2-b2035a10e6af1f88ba275283cf9654e1621eb3a5.zip
Initial version. Added also modifications from hasufell.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-libs/libsodium')
-rw-r--r--dev-libs/libsodium/ChangeLog9
-rw-r--r--dev-libs/libsodium/libsodium-0.4.3.ebuild28
-rw-r--r--dev-libs/libsodium/metadata.xml20
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libsodium/ChangeLog b/dev-libs/libsodium/ChangeLog
new file mode 100644
index 000000000000..c4299672a8c5
--- /dev/null
+++ b/dev-libs/libsodium/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-libs/libsodium
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/ChangeLog,v 1.1 2013/09/10 22:37:07 mrueg Exp $
+
+*libsodium-0.4.3 (10 Sep 2013)
+
+ 10 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +libsodium-0.4.3.ebuild,
+ +metadata.xml:
+ Initial version. Added also modifications from hasufell.
diff --git a/dev-libs/libsodium/libsodium-0.4.3.ebuild b/dev-libs/libsodium/libsodium-0.4.3.ebuild
new file mode 100644
index 000000000000..c602c409384d
--- /dev/null
+++ b/dev-libs/libsodium/libsodium-0.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsodium/libsodium-0.4.3.ebuild,v 1.1 2013/09/10 22:37:07 mrueg Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A portable fork of NaCl, a higher-level cryptographic library"
+HOMEPAGE="https://github.com/jedisct1/libsodium"
+SRC_URI="https://download.libsodium.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+asm static-libs +urandom"
+
+src_configure() {
+ econf \
+ $(use_enable asm) \
+ $(use_enable !urandom blocking-random) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/libsodium/metadata.xml b/dev-libs/libsodium/metadata.xml
new file mode 100644
index 000000000000..5933491f98b7
--- /dev/null
+++ b/dev-libs/libsodium/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+
+ <longdescription>
+ NaCl (pronounced "salt") is a new easy-to-use high-speed software library for
+ network communication, encryption, decryption, signatures, etc. NaCl's goal
+ is to provide all of the core operations needed to build higher-level
+ cryptographic tools. Sodium is a portable, cross-compilable, installable,
+ packageable fork of NaCl, with a compatible API.
+ </longdescription>
+ <use>
+ <flag name="asm">Enables assembly implementations</flag>
+ <flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
+ </use>
+</pkgmetadata>