summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-10-03 21:05:54 +0000
committerMart Raudsepp <leio@gentoo.org>2008-10-03 21:05:54 +0000
commit0a757de4c02085076581183031090bfc8481df4d (patch)
tree4348b791aca1cff2d913061560706215dee6a15e /dev-libs/libxml2
parentversion bump (diff)
downloadgentoo-2-0a757de4c02085076581183031090bfc8481df4d.tar.gz
gentoo-2-0a757de4c02085076581183031090bfc8481df4d.tar.bz2
gentoo-2-0a757de4c02085076581183031090bfc8481df4d.zip
New version with a small amount of bug fixes, including a fix for a DoS problem (infinite loop with growing memory usage) when there is an entity in an entity definition; bug 239346
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog9
-rw-r--r--dev-libs/libxml2/libxml2-2.7.2.ebuild121
2 files changed, 129 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index b418d9490820..f37337c712fe 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.226 2008/10/01 17:15:50 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.227 2008/10/03 21:05:54 leio Exp $
+
+*libxml2-2.7.2 (03 Oct 2008)
+
+ 03 Oct 2008; Mart Raudsepp <leio@gentoo.org> +libxml2-2.7.2.ebuild:
+ New version with a small amount of bug fixes, including a fix for a DoS
+ problem (infinite loop with growing memory usage) when there is an entity
+ in an entity definition; bug 239346
01 Oct 2008; Tobias Scherbaum <dertobi123@gentoo.org>
libxml2-2.7.1.ebuild:
diff --git a/dev-libs/libxml2/libxml2-2.7.2.ebuild b/dev-libs/libxml2/libxml2-2.7.2.ebuild
new file mode 100644
index 000000000000..8851082794b3
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.7.2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.2.ebuild,v 1.1 2008/10/03 21:05:54 leio Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bootstrap build debug doc examples ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ if use test; then
+ cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+ "${DISTDIR}/${XSTS_TARBALL_2}" \
+ "${S}"/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+
+ epunt_cxx
+}
+
+src_compile() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find "${S}" -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ if ! use doc; then
+ rm -rf "${D}"/usr/share/gtk-doc
+ rm -rf "${D}"/usr/share/doc/${P}/html
+ fi
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${P}/examples"
+ rm -rf "${D}/usr/share/doc/${PN}-python-${PV}/examples"
+ fi
+}
+
+pkg_postinst() {
+ # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+ # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+ if [[ "${ROOT}" != "/" ]]
+ then
+ elog "Skipping XML catalog creation for stage building (bug #208887)."
+ else
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+ fi
+}