summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-03-04 05:50:55 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-03-04 05:50:55 +0000
commit4d5736ebf3a38796400fa1e077f3a20a33000ca5 (patch)
treeb4b48515428dce49c97d34257ce4a525f48a33f5 /dev-libs/libxslt
parentMask multilib libxslt until multilib libgcrypt is unmasked (bug #480402). (diff)
downloadgentoo-2-4d5736ebf3a38796400fa1e077f3a20a33000ca5.tar.gz
gentoo-2-4d5736ebf3a38796400fa1e077f3a20a33000ca5.tar.bz2
gentoo-2-4d5736ebf3a38796400fa1e077f3a20a33000ca5.zip
Add multilib support (bug #480402, thanks to David Heidelberger (okias) and Michał Górny). Punt old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog10
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.28-libgcrypt-config.patch25
-rw-r--r--dev-libs/libxslt/libxslt-1.1.28-r2.ebuild104
-rw-r--r--dev-libs/libxslt/libxslt-1.1.28.ebuild114
4 files changed, 138 insertions, 115 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 005facdce46c..1aade5842522 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libxslt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.275 2014/03/01 22:09:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.276 2014/03/04 05:50:55 tetromino Exp $
+
+*libxslt-1.1.28-r2 (04 Mar 2014)
+
+ 04 Mar 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -libxslt-1.1.28.ebuild, +libxslt-1.1.28-r2.ebuild,
+ +files/libxslt-1.1.28-libgcrypt-config.patch:
+ Add multilib support (bug #480402, thanks to David Heidelberger (okias) and
+ Michał Górny). Punt old.
01 Mar 2014; Michał Górny <mgorny@gentoo.org> libxslt-1.1.28-r1.ebuild,
libxslt-1.1.28.ebuild:
diff --git a/dev-libs/libxslt/files/libxslt-1.1.28-libgcrypt-config.patch b/dev-libs/libxslt/files/libxslt-1.1.28-libgcrypt-config.patch
new file mode 100644
index 000000000000..2ed2b5548af1
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.28-libgcrypt-config.patch
@@ -0,0 +1,25 @@
+From 02dcd7d89b231af6ebe7704690de6ae7f8b31a84 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 4 Mar 2014 00:10:37 -0500
+Subject: [PATCH] configure: use AC_PATH_TOOL to find libgcrypt-config
+
+---
+ configure.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index a861e90..8328625 100644
+--- a/configure.in
++++ b/configure.in
+@@ -393,7 +393,7 @@ case $host in
+ CRYPTO_TESTDIR=crypto
+ ;;
+ *)
+- AC_PATH_PROG(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++ AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
+ if test "$LIBGCRYPT_CONFIG" != "no" ; then
+ LIBGCRYPT_VERSION=`$LIBGCRYPT_CONFIG --version`
+ if test VERSION_TO_NUMBER(echo $LIBGCRYPT_VERSION) -lt VERSION_TO_NUMBER(echo "1.1.42")
+--
+1.9.0
+
diff --git a/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild b/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
new file mode 100644
index 000000000000..0b40164eff56
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.28-r2.ebuild,v 1.1 2014/03/04 05:50:55 tetromino Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="xml"
+
+inherit autotools eutils python-r1 toolchain-funcs multilib-minimal
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="crypt debug python static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=dev-libs/libxml2-2.8.0:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.1.42:0=[${MULTILIB_USEDEP}] )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2[python,${PYTHON_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r20
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ DOCS=( AUTHORS ChangeLog FEATURES NEWS README TODO )
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=684621
+ epatch "${FILESDIR}"/${PN}.m4-${PN}-1.1.26.patch
+
+ epatch "${FILESDIR}"/${PN}-1.1.26-disable_static_modules.patch
+
+ # use AC_PATH_TOOL for libgcrypt-config for sane cross-compile and multilib support
+ # https://bugzilla.gnome.org/show_bug.cgi?id=725635
+ epatch "${FILESDIR}"/${PN}-1.1.28-libgcrypt-config.patch
+
+ # Python bindings are built/tested/installed manually.
+ epatch "${FILESDIR}"/${PN}-1.1.28-manual-python.patch
+
+ eautoreconf
+ # If eautoreconf'd with new autoconf, then epunt_cxx is not necessary
+ # and it is propably otherwise too if upstream generated with new
+ # autoconf
+# epunt_cxx
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf \
+ $(use_enable static-libs static) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-html-subdir=html \
+ $(use_with crypt crypto) \
+ $(multilib_build_binaries && use_with python || echo --without-python) \
+ $(use_with debug) \
+ $(use_with debug mem-debug)
+}
+
+multilib_src_compile() {
+ default
+ if use python && multilib_build_binaries; then
+ python_copy_sources
+ python_foreach_impl libxslt_py_emake
+ fi
+}
+
+multilib_src_test() {
+ default
+ use python && multilib_build_binaries && python_foreach_impl libxslt_py_emake test
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ if use python && multilib_build_binaries; then
+ python_foreach_impl libxslt_py_emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+ mv "${ED}"/usr/share/doc/${PN}-python-${PV} "${ED}"/usr/share/doc/${PF}/python
+ fi
+
+ prune_libtool_files --modules
+}
+
+libxslt_py_emake() {
+ pushd "${BUILD_DIR}/python" > /dev/null || die
+ emake \
+ PYTHON="${PYTHON}" \
+ PYTHON_INCLUDES="${EPREFIX}/usr/include/${EPYTHON}" \
+ PYTHON_LIBS="$(python-config --ldflags)" \
+ PYTHON_SITE_PACKAGES="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ PYTHON_VERSION=${EPYTHON/python} "$@"
+ popd > /dev/null
+}
diff --git a/dev-libs/libxslt/libxslt-1.1.28.ebuild b/dev-libs/libxslt/libxslt-1.1.28.ebuild
deleted file mode 100644
index 710c0b86f2c5..000000000000
--- a/dev-libs/libxslt/libxslt-1.1.28.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.28.ebuild,v 1.14 2014/03/01 22:09:55 mgorny Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="python? 2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-
-inherit autotools eutils python toolchain-funcs
-
-DESCRIPTION="XSLT libraries and tools"
-HOMEPAGE="http://www.xmlsoft.org/"
-SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="crypt debug python static-libs"
-
-RDEPEND=">=dev-libs/libxml2-2.8.0
- crypt? ( >=dev-libs/libgcrypt-1.1.42:0= )"
-DEPEND="${RDEPEND}"
-
-DOCS="AUTHORS ChangeLog FEATURES NEWS README TODO"
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=684621
- epatch "${FILESDIR}"/${PN}.m4-${PN}-1.1.26.patch
-
- epatch "${FILESDIR}"/${PN}-1.1.26-disable_static_modules.patch
-
- # Use python-config, not python2.7-config
- epatch "${FILESDIR}"/${PN}-1.1.27-python-config.patch
-
- # Python bindings are built/tested/installed manually.
- sed -i -e 's/$(PYTHON_SUBDIR)//' Makefile.am || die
-
- eautoreconf
-# epunt_cxx
-}
-
-src_configure() {
- # libgcrypt is missing pkg-config file, so fixing cross-compile
- # here. see bug 267503.
- tc-is-cross-compiler && \
- export LIBGCRYPT_CONFIG="${SYSROOT}"/usr/bin/libgcrypt-config
-
- econf \
- $(use_enable static-libs static) \
- --with-html-dir=/usr/share/doc/${PF} \
- --with-html-subdir=html \
- $(use_with crypt crypto) \
- $(use_with python) \
- $(use_with debug) \
- $(use_with debug mem-debug)
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources python
- building() {
- emake PYTHON_INCLUDES="$(python_get_includedir)" \
- PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_test() {
- default
-
- if use python; then
- testing() {
- emake test
- }
- python_execute_function -s --source-dir python testing
- fi
-}
-
-src_install() {
- default
-
- if use python; then
- installation() {
- emake DESTDIR="${D}" \
- PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
- install
- }
- python_execute_function -s --source-dir python installation
-
- python_clean_installation_image
-
- mv "${ED}"/usr/share/doc/${PN}-python-${PV} "${ED}"/usr/share/doc/${PF}/python
- fi
-
- prune_libtool_files
-}
-
-pkg_postinst() {
- use python && python_mod_optimize ${PN}.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}.py
-}