summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 16:35:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 16:35:13 +0000
commitf0add45c4c8672766d1cbb0ccfb8b386a88e8a8f (patch)
tree2b4cbfcbc019bbda707f03b82ef46f3faf9e7aff /dev-libs/libyaml
parentManifest fix, closes #260741 (diff)
downloadgentoo-2-f0add45c4c8672766d1cbb0ccfb8b386a88e8a8f.tar.gz
gentoo-2-f0add45c4c8672766d1cbb0ccfb8b386a88e8a8f.tar.bz2
gentoo-2-f0add45c4c8672766d1cbb0ccfb8b386a88e8a8f.zip
Bump to 0.1.2, fixes #259821, invalid test for FEATURES changed into USE=test check
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libyaml')
-rw-r--r--dev-libs/libyaml/ChangeLog11
-rw-r--r--dev-libs/libyaml/libyaml-0.0.1.ebuild6
-rw-r--r--dev-libs/libyaml/libyaml-0.1.2.ebuild37
3 files changed, 49 insertions, 5 deletions
diff --git a/dev-libs/libyaml/ChangeLog b/dev-libs/libyaml/ChangeLog
index 48f282645318..bc880002ca77 100644
--- a/dev-libs/libyaml/ChangeLog
+++ b/dev-libs/libyaml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libyaml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/ChangeLog,v 1.2 2007/10/16 00:52:43 sbriesen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/ChangeLog,v 1.3 2009/03/01 16:35:13 patrick Exp $
+
+*libyaml-0.1.2 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> libyaml-0.0.1.ebuild,
+ +libyaml-0.1.2.ebuild:
+ Bump to 0.1.2, fixes #259821, invalid test for FEATURES changed into
+ USE=test check
16 Oct 2007; Stefan Briesenick <sbriesen@gentoo.org> libyaml-0.0.1.ebuild:
some cleanups
diff --git a/dev-libs/libyaml/libyaml-0.0.1.ebuild b/dev-libs/libyaml/libyaml-0.0.1.ebuild
index b03e281ffc22..c3c174234f72 100644
--- a/dev-libs/libyaml/libyaml-0.0.1.ebuild
+++ b/dev-libs/libyaml/libyaml-0.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.0.1.ebuild,v 1.3 2007/12/31 05:34:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.0.1.ebuild,v 1.4 2009/03/01 16:35:13 patrick Exp $
inherit eutils
@@ -21,7 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
# conditionally remove tests
- if ! hasq test ${FEATURES} ; then
+ if use test ; then
sed -i -e 's: tests::g' Makefile*
fi
}
diff --git a/dev-libs/libyaml/libyaml-0.1.2.ebuild b/dev-libs/libyaml/libyaml-0.1.2.ebuild
new file mode 100644
index 000000000000..f002d548646e
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.1.2.ebuild,v 1.1 2009/03/01 16:35:13 patrick Exp $
+
+inherit eutils
+
+MY_P="${P/lib}"
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="http://pyyaml.org/wiki/LibYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # conditionally remove tests
+ if use test ; then
+ sed -i -e 's: tests::g' Makefile*
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use doc && dohtml -r doc/html/.
+ dodoc README
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/example-*.c
+ fi
+}