summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-15 17:47:58 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-15 17:47:58 +0000
commit456c61802c1ccc1ec23a49c2b3d5f49e5da415a0 (patch)
tree2b0bde2258be48163ebbbb3d7c1735ec15c4a26c /dev-libs/log4c/log4c-1.2.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.tar.gz
gentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.tar.bz2
gentoo-2-456c61802c1ccc1ec23a49c2b3d5f49e5da415a0.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-libs/log4c/log4c-1.2.4.ebuild')
-rw-r--r--dev-libs/log4c/log4c-1.2.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/log4c/log4c-1.2.4.ebuild b/dev-libs/log4c/log4c-1.2.4.ebuild
new file mode 100644
index 000000000000..27bf4ec39ba3
--- /dev/null
+++ b/dev-libs/log4c/log4c-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/log4c/log4c-1.2.4.ebuild,v 1.1 2014/10/15 17:47:58 kensington Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Log4c is a library of C for flexible logging to files, syslog and other destinations"
+HOMEPAGE="http://log4c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/log4c/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples +expat static-libs"
+
+RDEPEND="expat? ( dev-libs/expat )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}/${P}-docdir.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-expattest
+ $(use_enable debug)
+ $(use_enable doc)
+ )
+
+ use expat || myeconfargs+=( --without-expat )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}