summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-02 10:38:42 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-02 10:38:42 +0000
commitb7e26a1ab73f6918a34aedcc7de659c9a9140f57 (patch)
tree8468a642a062812846627cb5606d61e1de6b9e2a /dev-libs/maloc
parentsci-mathematics/gimps: Fix checksums again, #414073 (diff)
downloadgentoo-2-b7e26a1ab73f6918a34aedcc7de659c9a9140f57.tar.gz
gentoo-2-b7e26a1ab73f6918a34aedcc7de659c9a9140f57.tar.bz2
gentoo-2-b7e26a1ab73f6918a34aedcc7de659c9a9140f57.zip
dev-libs/maloc: Move to autotools-utils.eclass
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/maloc')
-rw-r--r--dev-libs/maloc/ChangeLog7
-rw-r--r--dev-libs/maloc/maloc-1.5.ebuild46
2 files changed, 27 insertions, 26 deletions
diff --git a/dev-libs/maloc/ChangeLog b/dev-libs/maloc/ChangeLog
index c5c8d230b01c..d247119ac1f0 100644
--- a/dev-libs/maloc/ChangeLog
+++ b/dev-libs/maloc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/maloc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/ChangeLog,v 1.23 2011/07/20 16:53:17 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/ChangeLog,v 1.24 2012/05/02 10:38:42 jlec Exp $
+
+ 02 May 2012; Justin Lecher <jlec@gentoo.org> maloc-1.5.ebuild:
+ Move to autotools-utils.eclass
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #105599
diff --git a/dev-libs/maloc/maloc-1.5.ebuild b/dev-libs/maloc/maloc-1.5.ebuild
index 5ff459988563..5cc69b362228 100644
--- a/dev-libs/maloc/maloc-1.5.ebuild
+++ b/dev-libs/maloc/maloc-1.5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-1.5.ebuild,v 1.2 2011/04/16 06:56:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/maloc/maloc-1.5.ebuild,v 1.3 2012/05/02 10:38:42 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
DESCRIPTION="Minimal Abstraction Layer for Object-oriented C/C++ programs"
HOMEPAGE="http://www.fetk.org/codes/maloc/index.html"
@@ -25,32 +27,28 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/1.4-mpi.patch \
- "${FILESDIR}"/1.4-asneeded.patch \
- "${FILESDIR}"/1.4-doc.patch
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/1.4-mpi.patch
+ "${FILESDIR}"/1.4-asneeded.patch
+ "${FILESDIR}"/1.4-doc.patch
+ )
src_configure() {
- local myconf
+ local myeconfargs
use mpi && export CC="mpicc"
- use doc || myconf="${myconf} --with-doxygen= --with-dot="
-
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable mpi) \
- $(use_enable static-libs static) \
- --disable-triplet \
- --enable-shared \
- ${myconf}
+ use doc || myeconfargs+=( --with-doxygen= --with-dot= )
+
+ myeconfargs+=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable mpi)
+ --disable-triplet
+ )
+ autotools-utils_src_configure
}
src_install() {
- # install libs and headers
- emake DESTDIR="${D}" install || die "make install failed"
+ autotools-utils_src_install
# install doc
- dohtml doc/index.html || die "failed to install html docs"
+ dohtml doc/index.html
}