summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-03-17 10:43:27 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-03-17 10:43:27 +0000
commite131c287ee222d8c64c6376f7d4c628b87d4ea84 (patch)
treec7732a96ab6fb458ea71df2d1bb7aba2608cab16 /dev-libs/mongo-cxx-driver
parentversion bump (diff)
downloadgentoo-2-e131c287ee222d8c64c6376f7d4c628b87d4ea84.tar.gz
gentoo-2-e131c287ee222d8c64c6376f7d4c628b87d4ea84.tar.bz2
gentoo-2-e131c287ee222d8c64c6376f7d4c628b87d4ea84.zip
news dev-libs/mongo-cxx-driver ebuild
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs/mongo-cxx-driver')
-rw-r--r--dev-libs/mongo-cxx-driver/ChangeLog10
-rw-r--r--dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.0.0-fix-scons.patch34
-rw-r--r--dev-libs/mongo-cxx-driver/metadata.xml16
-rw-r--r--dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.0.ebuild69
4 files changed, 129 insertions, 0 deletions
diff --git a/dev-libs/mongo-cxx-driver/ChangeLog b/dev-libs/mongo-cxx-driver/ChangeLog
new file mode 100644
index 000000000000..7f877e54a8de
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/mongo-cxx-driver
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-cxx-driver/ChangeLog,v 1.1 2015/03/17 10:43:27 ultrabug Exp $
+
+*mongo-cxx-driver-1.0.0 (17 Mar 2015)
+
+ 17 Mar 2015; Ultrabug <ultrabug@gentoo.org> +mongo-cxx-driver-1.0.0.ebuild,
+ +files/mongo-cxx-driver-1.0.0-fix-scons.patch, +metadata.xml:
+ new ebuild dev-libs/mongo-cxx-driver
+
diff --git a/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.0.0-fix-scons.patch b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.0.0-fix-scons.patch
new file mode 100644
index 000000000000..319773c7d571
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/files/mongo-cxx-driver-1.0.0-fix-scons.patch
@@ -0,0 +1,34 @@
+--- a/SConstruct 2015-03-17 10:19:58.766530807 +0100
++++ b/SConstruct 2015-03-17 10:27:58.400062874 +0100
+@@ -853,7 +853,6 @@
+
+ # -Winvalid-pch Warn if a precompiled header (see Precompiled Headers) is found in the search path but can't be used.
+ env.Append( CCFLAGS=["-fPIC",
+- "-ggdb",
+ "-pthread",
+ "-Wall",
+ "-Wsign-compare",
+@@ -861,13 +860,13 @@
+ "-Winvalid-pch"] )
+ # env.Append( " -Wconversion" ) TODO: this doesn't really work yet
+ if linux or darwin:
+- env.Append( CCFLAGS=["-pipe"] )
+ if not has_option("disable-warnings-as-errors"):
+ env.Append( CCFLAGS=["-Werror"] )
+
+ env.Append( CPPDEFINES=["_FILE_OFFSET_BITS=64"] )
+- env.Append( CXXFLAGS=["-Wnon-virtual-dtor", "-Woverloaded-virtual"] )
+ env.Append( LINKFLAGS=["-fPIC"] )
++ env.Append( CXXFLAGS=os.environ['CXXFLAGS'] )
++ env.Append( LINKFLAGS=os.environ['LDFLAGS'] )
+
+ # SERVER-9761: Ensure early detection of missing symbols in dependent libraries at program
+ # startup.
+@@ -933,7 +932,6 @@
+ except OSError:
+ pass
+
+-env.Prepend(CPPPATH=['$VARIANT_DIR/third_party/gtest-1.7.0/include'])
+
+ boostSuffixList = ["-mt", ""]
+ if get_option("boost-lib-search-suffixes") is not None:
diff --git a/dev-libs/mongo-cxx-driver/metadata.xml b/dev-libs/mongo-cxx-driver/metadata.xml
new file mode 100644
index 000000000000..66a0debe8bd4
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Alexys Jacob</name>
+ </maintainer>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.0.ebuild b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.0.ebuild
new file mode 100644
index 000000000000..4ed4cef93c1f
--- /dev/null
+++ b/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-cxx-driver/mongo-cxx-driver-1.0.0.ebuild,v 1.1 2015/03/17 10:43:27 ultrabug Exp $
+
+EAPI=5
+SCONS_MIN_VERSION="2.3.0"
+
+inherit eutils flag-o-matic multilib scons-utils
+
+DESCRIPTION="C++ Driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-cxx-driver"
+SRC_URI="https://github.com/mongodb/${PN}/archive/legacy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug sasl ssl static-libs"
+
+RDEPEND=">=dev-libs/boost-1.50[threads(+)]
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+
+# Maintainer notes
+# TODO: enable test in IUSE with
+# test? ( >=dev-cpp/gtest-1.7.0 dev-db/mongodb )
+
+DOCS=( README.md )
+
+S="${WORKDIR}/${PN}-legacy-${PV}"
+
+pkg_setup() {
+ scons_opts="--variant-dir=build --cc=$(tc-getCC) --cxx=$(tc-getCXX)"
+ scons_opts+=" --disable-warnings-as-errors --sharedclient"
+
+ if use debug; then
+ scons_opts+=" --dbg=on"
+ fi
+
+ if use prefix; then
+ scons_opts+=" --cpppath=${EPREFIX}/usr/include"
+ scons_opts+=" --libpath=${EPREFIX}/usr/$(get_libdir)"
+ fi
+
+ if use sasl; then
+ scons_opts+=" --use-sasl-client"
+ fi
+
+ if use ssl; then
+ scons_opts+=" --ssl"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.0.0-fix-scons.patch"
+
+ # respect mongoDB upstream's basic recommendations
+ # see bug #536688 and #526114
+ if ! use debug; then
+ filter-flags '-m*'
+ filter-flags '-O?'
+ fi
+}
+
+src_install() {
+ escons ${scons_opts} install --prefix="${ED}"/usr
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}