summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-03-02 00:03:24 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-03-02 00:03:24 +0000
commit6415c797d8b7ac0715b790980dd36fda591a0cd6 (patch)
treed91016fe0f00703f69d9c812ee7b200041327517 /dev-libs/msgpack
parentInitial import. (diff)
downloadgentoo-2-6415c797d8b7ac0715b790980dd36fda591a0cd6.tar.gz
gentoo-2-6415c797d8b7ac0715b790980dd36fda591a0cd6.tar.bz2
gentoo-2-6415c797d8b7ac0715b790980dd36fda591a0cd6.zip
Initial import.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/msgpack')
-rw-r--r--dev-libs/msgpack/ChangeLog10
-rw-r--r--dev-libs/msgpack/files/msgpack-0.4.2-test.patch11
-rw-r--r--dev-libs/msgpack/metadata.xml9
-rw-r--r--dev-libs/msgpack/msgpack-0.4.2.ebuild29
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/msgpack/ChangeLog b/dev-libs/msgpack/ChangeLog
new file mode 100644
index 000000000000..626156602884
--- /dev/null
+++ b/dev-libs/msgpack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/msgpack
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/msgpack/ChangeLog,v 1.1 2010/03/02 00:03:23 matsuu Exp $
+
+*msgpack-0.4.2 (02 Mar 2010)
+
+ 02 Mar 2010; MATSUU Takuto <matsuu@gentoo.org> +msgpack-0.4.2.ebuild,
+ +files/msgpack-0.4.2-test.patch, +metadata.xml:
+ Initial import.
+
diff --git a/dev-libs/msgpack/files/msgpack-0.4.2-test.patch b/dev-libs/msgpack/files/msgpack-0.4.2-test.patch
new file mode 100644
index 000000000000..dde96b83790e
--- /dev/null
+++ b/dev-libs/msgpack/files/msgpack-0.4.2-test.patch
@@ -0,0 +1,11 @@
+diff -Naur msgpack-0.4.2.orig//cpp/Makefile.am msgpack-0.4.2//cpp/Makefile.am
+--- msgpack-0.4.2.orig//cpp/Makefile.am 2010-02-18 14:31:42.000000000 +0900
++++ msgpack-0.4.2//cpp/Makefile.am 2010-03-02 01:43:12.000000000 +0900
+@@ -39,6 +39,6 @@
+
+ msgpack_test_SOURCES = test.cpp
+ msgpack_test_CXXFLAGS = -I$(top_srcdir) -I$(top_srcdir)/c -I$(top_srcdir)/cpp
+-msgpack_test_LDADD = libmsgpack.la -lgtest_main
++msgpack_test_LDADD = -L../c -lmsgpackc libmsgpack.la -lgtest_main
+
+ TESTS = $(check_PROGRAMS)
diff --git a/dev-libs/msgpack/metadata.xml b/dev-libs/msgpack/metadata.xml
new file mode 100644
index 000000000000..5b14597b8ad0
--- /dev/null
+++ b/dev-libs/msgpack/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
+
diff --git a/dev-libs/msgpack/msgpack-0.4.2.ebuild b/dev-libs/msgpack/msgpack-0.4.2.ebuild
new file mode 100644
index 000000000000..ee722fc8f512
--- /dev/null
+++ b/dev-libs/msgpack/msgpack-0.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/msgpack/msgpack-0.4.2.ebuild,v 1.1 2010/03/02 00:03:23 matsuu Exp $
+
+EAPI="2"
+inherit autotools eutils
+
+DESCRIPTION="MessagePack is a binary-based efficient data interchange format"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/46155/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-util/gtest )"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-test.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}