summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-04 20:50:38 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-04 20:50:38 +0000
commit0dc81d168eef9409b40ae2298b60fa4c3ef0614f (patch)
treec0d387d41b98c359a9960209691aa1601943b810 /dev-libs/redland
parentAdd 6.1.19 into the tree, in p.mask as upstream testsuite still has failures,... (diff)
downloadgentoo-2-0dc81d168eef9409b40ae2298b60fa4c3ef0614f.tar.gz
gentoo-2-0dc81d168eef9409b40ae2298b60fa4c3ef0614f.tar.bz2
gentoo-2-0dc81d168eef9409b40ae2298b60fa4c3ef0614f.zip
Utilize db-use.eclass to obtain proper include path & library for berkdb. Bugs #519002 and #476376.
(Portage version: 2.2.11_p4/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/redland')
-rw-r--r--dev-libs/redland/ChangeLog6
-rw-r--r--dev-libs/redland/redland-1.0.16.ebuild20
2 files changed, 19 insertions, 7 deletions
diff --git a/dev-libs/redland/ChangeLog b/dev-libs/redland/ChangeLog
index 23d1814893df..dd8e48362352 100644
--- a/dev-libs/redland/ChangeLog
+++ b/dev-libs/redland/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/redland
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.121 2014/08/01 05:16:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.122 2014/08/04 20:50:38 mgorny Exp $
+
+ 04 Aug 2014; Michał Górny <mgorny@gentoo.org> redland-1.0.16.ebuild:
+ Utilize db-use.eclass to obtain proper include path & library for berkdb. Bugs
+ #519002 and #476376.
01 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> redland-1.0.16.ebuild:
Punt unused USE="ssl" and dev-libs/openssl dependency wrt #518706 by
diff --git a/dev-libs/redland/redland-1.0.16.ebuild b/dev-libs/redland/redland-1.0.16.ebuild
index c9fa907ccb8e..a5c1ee323421 100644
--- a/dev-libs/redland/redland-1.0.16.ebuild
+++ b/dev-libs/redland/redland-1.0.16.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.16.ebuild,v 1.13 2014/08/01 05:16:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.16.ebuild,v 1.14 2014/08/04 20:50:38 mgorny Exp $
EAPI=4
-inherit libtool
+inherit db-use libtool
DESCRIPTION="High-level interface for the Resource Description Framework"
HOMEPAGE="http://librdf.org/"
@@ -37,11 +37,19 @@ src_configure() {
local parser=expat
use xml && parser=libxml
- local myconf="--without-virtuoso"
+ local myconf=( --without-virtuoso )
if use iodbc; then
- myconf="--with-virtuoso --with-iodbc --without-unixodbc"
+ myconf=( --with-virtuoso --with-iodbc --without-unixodbc )
elif use odbc; then
- myconf="--with-virtuoso --with-unixodbc --without-iodbc"
+ myconf=( --with-virtuoso --with-unixodbc --without-iodbc )
+ fi
+
+ if use berkdb; then
+ myconf+=(
+ --with-bdb-include="$(db_includedir)"
+ --with-bdb-lib="${EPREFIX}"/usr/$(get_libdir)
+ --with-bdb-dbname="$(db_libname)"
+ )
fi
# FIXME: upstream doesn't test with --with-threads and testsuite fails
@@ -54,7 +62,7 @@ src_configure() {
$(use_with postgres postgresql) \
--without-threads \
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
- ${myconf}
+ "${myconf[@]}"
}
src_compile() {