summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-09-01 10:01:36 +0000
committerChristian Heim <phreak@gentoo.org>2007-09-01 10:01:36 +0000
commit9e764ef06de4dc5ea53c8d0792934559e4674579 (patch)
tree3ed643eabc284fd9b7bcf67a0becabc23301274f /dev-libs/redland
parentFixing compilation on FreeBSD (thanks to Toffanin [WiredTEK] <equilibrium at ... (diff)
downloadgentoo-2-9e764ef06de4dc5ea53c8d0792934559e4674579.tar.gz
gentoo-2-9e764ef06de4dc5ea53c8d0792934559e4674579.tar.bz2
gentoo-2-9e764ef06de4dc5ea53c8d0792934559e4674579.zip
Fixing compilation against >db-4.4, as mentioned by Roy in #190682.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-libs/redland')
-rw-r--r--dev-libs/redland/ChangeLog8
-rw-r--r--dev-libs/redland/files/digest-redland-1.0.6-r13
-rw-r--r--dev-libs/redland/files/redland-1.0.6-db4.5.patch11
-rw-r--r--dev-libs/redland/redland-1.0.6-r1.ebuild50
4 files changed, 71 insertions, 1 deletions
diff --git a/dev-libs/redland/ChangeLog b/dev-libs/redland/ChangeLog
index a56881f56533..08c8f7b41c5e 100644
--- a/dev-libs/redland/ChangeLog
+++ b/dev-libs/redland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/redland
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.23 2007/09/01 09:40:39 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.24 2007/09/01 10:01:36 phreak Exp $
+
+*redland-1.0.6-r1 (01 Sep 2007)
+
+ 01 Sep 2007; Christian Heim <phreak@gentoo.org>
+ +files/redland-1.0.6-db4.5.patch, +redland-1.0.6-r1.ebuild:
+ Fixing compilation against >db-4.4, as mentioned by Roy in #190682.
01 Sep 2007; Christian Heim <phreak@gentoo.org>
+files/redland-1.0.6-fbsd.patch, redland-1.0.6.ebuild:
diff --git a/dev-libs/redland/files/digest-redland-1.0.6-r1 b/dev-libs/redland/files/digest-redland-1.0.6-r1
new file mode 100644
index 000000000000..aa852a3d124e
--- /dev/null
+++ b/dev-libs/redland/files/digest-redland-1.0.6-r1
@@ -0,0 +1,3 @@
+MD5 901bf87252658c8b247dc6eda00f8724 redland-1.0.6.tar.gz 3558222
+RMD160 3f57b2646ec73f89fb93c22062ad7e8d2ad01665 redland-1.0.6.tar.gz 3558222
+SHA256 bcbf026735faf805b692820a2870d39f7fdf8425076bd689df6a10cf8d46159a redland-1.0.6.tar.gz 3558222
diff --git a/dev-libs/redland/files/redland-1.0.6-db4.5.patch b/dev-libs/redland/files/redland-1.0.6-db4.5.patch
new file mode 100644
index 000000000000..d6d148995a38
--- /dev/null
+++ b/dev-libs/redland/files/redland-1.0.6-db4.5.patch
@@ -0,0 +1,11 @@
+--- redland-1.0.6/configure.ac
++++ redland-1.0.6/configure.ac
+@@ -237,7 +237,7 @@ if test "x$bdb_prefix" != "xno" ; then
+ fi
+
+ # Sigh! And this still might not be good enough.
+- for bdbc_version in 4.4 4.3 4.2 4.1 4.0 4 3.3 3.2 3.1 3 2; do
++ for bdbc_version in 4.6 4.5 4.4 4.3 4.2 4.1 4.0 4 3.3 3.2 3.1 3 2; do
+ bdbc_major=`echo $bdbc_version | sed -e 's/^\(.\).*$/\1/'`;
+ bdbc_version2=`echo $bdbc_version | sed -e 's/^\(.\).\(.\)$/\1\2/'`
+
diff --git a/dev-libs/redland/redland-1.0.6-r1.ebuild b/dev-libs/redland/redland-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..8e1581eaaae3
--- /dev/null
+++ b/dev-libs/redland/redland-1.0.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.6-r1.ebuild,v 1.1 2007/09/01 10:01:36 phreak Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="High-level interface for the Resource Description Framework"
+HOMEPAGE="http://librdf.org/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="berkdb mysql sqlite ssl threads"
+
+DEPEND="mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-3* )
+ berkdb? ( sys-libs/db )
+ dev-libs/libxml2
+ ssl? ( dev-libs/openssl )
+ >=media-libs/raptor-1.4.4
+ >=dev-libs/rasqal-0.9.14"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf {raptor,rasqal}
+ epatch "${FILESDIR}"/${P}-fbsd.patch
+ epatch "${FILESDIR}"/${P}-db4.5.patch
+ eautoconf
+}
+
+src_compile() {
+ econf \
+ --with-raptor=system \
+ --with-rasqal=system \
+ $(use_with berkdb bdb) \
+ $(use_with ssl openssl-digests) \
+ $(use_with mysql) \
+ $(use_with threads) \
+ $(use_with sqlite) \
+ || die "econf failed!"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed!"
+ dodoc AUTHORS ChangeLog* INSTALL NEWS README TODO
+ dohtml *.html
+}