summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-22 04:04:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-22 04:04:07 +0000
commit9ab3076936832cb3f9d0f398d0ae696730be3c3b (patch)
treea846bc6beb9c0986a42076efba0e75cacc10237a /dev-libs/tomsfastmath
parentold (diff)
downloadgentoo-2-9ab3076936832cb3f9d0f398d0ae696730be3c3b.tar.gz
gentoo-2-9ab3076936832cb3f9d0f398d0ae696730be3c3b.tar.bz2
gentoo-2-9ab3076936832cb3f9d0f398d0ae696730be3c3b.zip
Fix building on x86 #152043.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'dev-libs/tomsfastmath')
-rw-r--r--dev-libs/tomsfastmath/ChangeLog6
-rw-r--r--dev-libs/tomsfastmath/files/digest-tomsfastmath-0.052
-rw-r--r--dev-libs/tomsfastmath/files/tomsfastmath-0.05-asm-relax-x86.patch16
-rw-r--r--dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild11
4 files changed, 33 insertions, 2 deletions
diff --git a/dev-libs/tomsfastmath/ChangeLog b/dev-libs/tomsfastmath/ChangeLog
index a15158c46b99..fa1fe27aa4a7 100644
--- a/dev-libs/tomsfastmath/ChangeLog
+++ b/dev-libs/tomsfastmath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/tomsfastmath
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tomsfastmath/ChangeLog,v 1.3 2006/03/19 22:34:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tomsfastmath/ChangeLog,v 1.4 2006/10/22 04:04:07 vapier Exp $
+
+ 22 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/tomsfastmath-0.05-asm-relax-x86.patch, tomsfastmath-0.05.ebuild:
+ Fix building on x86 #152043.
19 Mar 2006; Mark Loeser <halcy0n@gentoo.org> tomsfastmath-0.03.ebuild,
tomsfastmath-0.05.ebuild:
diff --git a/dev-libs/tomsfastmath/files/digest-tomsfastmath-0.05 b/dev-libs/tomsfastmath/files/digest-tomsfastmath-0.05
index 772d5e8cd235..0645e832ee03 100644
--- a/dev-libs/tomsfastmath/files/digest-tomsfastmath-0.05
+++ b/dev-libs/tomsfastmath/files/digest-tomsfastmath-0.05
@@ -1 +1,3 @@
MD5 0b4a0e82c06c5377368c2f6718b7f5f2 tfm-0.05.zip 318329
+RMD160 2321497af66088bd1935fd83abad3924117b976e tfm-0.05.zip 318329
+SHA256 62a36a9d7630b299cf2169899b9591b9fd5fa380bfb5272504ff3f4c900d4a09 tfm-0.05.zip 318329
diff --git a/dev-libs/tomsfastmath/files/tomsfastmath-0.05-asm-relax-x86.patch b/dev-libs/tomsfastmath/files/tomsfastmath-0.05-asm-relax-x86.patch
new file mode 100644
index 000000000000..959dc0246166
--- /dev/null
+++ b/dev-libs/tomsfastmath/files/tomsfastmath-0.05-asm-relax-x86.patch
@@ -0,0 +1,16 @@
+relax input constraints for x86 so gcc doesnt error out:
+fp_mul_comba.c:258: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
+
+http://bugs.gentoo.org/152043
+
+--- fp_mul_comba.c
++++ fp_mul_comba.c
+@@ -53,7 +53,7 @@
+ "addl %%eax,%0 \n\t" \
+ "adcl %%edx,%1 \n\t" \
+ "adcl $0,%2 \n\t" \
+- :"=r"(c0), "=r"(c1), "=r"(c2): "0"(c0), "1"(c1), "2"(c2), "m"(i), "m"(j) :"%eax","%edx","%cc");
++ :"=r"(c0), "=r"(c1), "=r"(c2): "0"(c0), "1"(c1), "2"(c2), "g"(i), "g"(j) :"%eax","%edx","%cc");
+
+ #elif defined(TFM_X86_64)
+ /* x86-64 optimized */
diff --git a/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild b/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild
index f7d1128f3c8e..d7d1bc38c5cb 100644
--- a/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild
+++ b/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild,v 1.3 2006/03/19 22:34:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/tomsfastmath/tomsfastmath-0.05.ebuild,v 1.4 2006/10/22 04:04:07 vapier Exp $
+
+inherit eutils
DESCRIPTION="portable fixed precision math library geared towards doing one thing very fast"
HOMEPAGE="http://libtomcrypt.org/tfm/"
@@ -10,9 +12,16 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 arm ppc x86"
IUSE=""
+
DEPEND="app-arch/unzip"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asm-relax-x86.patch #152043
+}
+
src_compile() {
emake IGNORE_SPEED=1 || die
}