summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-05-05 15:20:33 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-05-05 15:20:33 +0000
commitd2f734b1fcb8452c759ca0eff56e8564ce94455d (patch)
treeac13ec11c4068b3dbe5f557c941e001305ac391e /dev-libs/totem-pl-parser
parentfix repoman warnings (diff)
downloadgentoo-2-d2f734b1fcb8452c759ca0eff56e8564ce94455d.tar.gz
gentoo-2-d2f734b1fcb8452c759ca0eff56e8564ce94455d.tar.bz2
gentoo-2-d2f734b1fcb8452c759ca0eff56e8564ce94455d.zip
Better fix for GTKDOC_REBASE problem (from totem ebuild in-overlay) -- thanks to eva for pointing it out
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs/totem-pl-parser')
-rw-r--r--dev-libs/totem-pl-parser/ChangeLog7
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild20
2 files changed, 18 insertions, 9 deletions
diff --git a/dev-libs/totem-pl-parser/ChangeLog b/dev-libs/totem-pl-parser/ChangeLog
index 525bbcdaa833..7ffc92e405e0 100644
--- a/dev-libs/totem-pl-parser/ChangeLog
+++ b/dev-libs/totem-pl-parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/totem-pl-parser
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.28 2009/05/05 13:25:23 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/ChangeLog,v 1.29 2009/05/05 15:20:33 nirbheek Exp $
+
+ 05 May 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ totem-pl-parser-2.26.1.ebuild:
+ Better fix for GTKDOC_REBASE problem (from totem ebuild in-overlay) --
+ thanks to eva for pointing it out
05 May 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
totem-pl-parser-2.26.1.ebuild,
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
index 081821b3aca6..fcf2b4d55081 100644
--- a/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild,v 1.3 2009/05/05 13:25:23 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.26.1.ebuild,v 1.4 2009/05/05 15:20:33 nirbheek Exp $
EAPI="2"
@@ -29,19 +29,23 @@ G2CONF="${G2CONF} --disable-static"
src_prepare() {
gnome2_src_prepare
+ # FIXME: tarball generated with broken gtk-doc, revisit me.
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
+ -i gtk-doc.make || die "sed 1 failed"
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=$(type -P true)" \
+ -i gtk-doc.make || die "sed 2 failed"
+ fi
+
# Conditional patching is purely to avoid eautoreconf
if use test && ! use doc; then
+ # http://bugzilla.gnome.org/show_bug.cgi?id=577774
epatch "${FILESDIR}/${P}-fix-tests-without-gtk-doc.patch"
eautoreconf
fi
}
src_install() {
- if use test && ! use doc; then
- # Weird bug with empty GTKDOC_REBASE because of above patch
- local gtkdoc_rebase="! which gtkdoc-rebase >/dev/null 2>&1 || gtkdoc-rebase"
- emake DESTDIR="${D}" GTKDOC_REBASE="${gtkdoc_rebase}" install || die "install failed"
- else
- emake DESTDIR="${D}" install || die "install failed"
- fi
+ emake DESTDIR="${D}" install || die "install failed"
}