summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-10-14 00:46:04 +0000
committerChris White <chriswhite@gentoo.org>2004-10-14 00:46:04 +0000
commita1d42c9994d8bc2c58cc2446f9bf82e1f580cdc1 (patch)
tree928a903f8a2326aec90345e324c59095df2f6b74 /dev-libs/vdk/vdk-2.4.0.ebuild
parent+us -> u+s (Manifest recommit) (diff)
downloadgentoo-2-a1d42c9994d8bc2c58cc2446f9bf82e1f580cdc1.tar.gz
gentoo-2-a1d42c9994d8bc2c58cc2446f9bf82e1f580cdc1.tar.bz2
gentoo-2-a1d42c9994d8bc2c58cc2446f9bf82e1f580cdc1.zip
bump to 2.4.0. Part of fixing Bug #6740. Also applied an upstream gcc 3.4 patch (after some modification).
Diffstat (limited to 'dev-libs/vdk/vdk-2.4.0.ebuild')
-rw-r--r--dev-libs/vdk/vdk-2.4.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/vdk/vdk-2.4.0.ebuild b/dev-libs/vdk/vdk-2.4.0.ebuild
new file mode 100644
index 000000000000..4ea3672f79e7
--- /dev/null
+++ b/dev-libs/vdk/vdk-2.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vdk/vdk-2.4.0.ebuild,v 1.1 2004/10/14 00:46:04 chriswhite Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Visual Development Kit for RAD"
+SRC_URI="mirror://sourceforge/vdkbuilder/${P}.tar.gz"
+HOMEPAGE="http://vdk.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa"
+IUSE="doc debug"
+
+DEPEND=">x11-libs/gtk+-2.4*
+ doc? (app-doc/doxygen)"
+
+src_compile() {
+ cd ${S}
+
+ if [ "$(gcc-major-version)" -ge "4" ] || [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]
+ then
+ epatch ${FILESDIR}/${P}-gcc3.4.patch
+ fi
+
+ # gnome and sigc USE flags need to be added later
+ # when upstream decides to re-support them - ChrisWhite
+
+ use doc && \
+ myconf="${myconf} --enable-doc-html=yes \
+ --enable-doc-latex=yes \
+ --enable-doc-man=yes"
+
+ use debug && \
+ myconf="${myconf} --enable-debug=yes"
+
+ econf \
+ ${myconf} \
+ --with-gnu-ld \
+ --enable-testvdk=no \
+ || die "econf failed"
+
+ # die non user custom CFLAGS!
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i Makefile
+ sed -e "s/CFLAGS = .*/CFLAGS = ${CFLAGS}/" -i vdk/Makefile
+ sed -e "s/CXXFLAGS = .*/CXXFLAGS = ${CXXFLAGS}/" -i vdk/Makefile
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}