summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-03 11:25:53 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-06-03 11:25:53 +0000
commitb0ab6b334a20981ad2376231a705c40bb18b5763 (patch)
tree06d1349995159f4b971d1e66baf12c92cdbdc16d /dev-libs/xapian
parentAdd pypi to remote-id in metadata.xml (diff)
downloadgentoo-2-b0ab6b334a20981ad2376231a705c40bb18b5763.tar.gz
gentoo-2-b0ab6b334a20981ad2376231a705c40bb18b5763.tar.bz2
gentoo-2-b0ab6b334a20981ad2376231a705c40bb18b5763.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/ChangeLog7
-rw-r--r--dev-libs/xapian/xapian-1.3.3.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 4610e5e241e7..4c1896cc23bd 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.144 2015/05/23 14:59:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.145 2015/06/03 11:25:53 blueness Exp $
+
+*xapian-1.3.3 (03 Jun 2015)
+
+ 03 Jun 2015; Anthony G. Basile <blueness@gentoo.org> +xapian-1.3.3.ebuild:
+ Version bump
*xapian-1.2.21 (23 May 2015)
diff --git a/dev-libs/xapian/xapian-1.3.3.ebuild b/dev-libs/xapian/xapian-1.3.3.ebuild
new file mode 100644
index 000000000000..cafe0406f78e
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.3.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.3.3.ebuild,v 1.1 2015/06/03 11:25:53 blueness Exp $
+
+EAPI="5"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use cpu_flags_x86_sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}