summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-04-22 21:07:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-04-22 21:07:10 +0000
commit491956353236f738f561609f78d1e4d61a960369 (patch)
treeeb6cca27b7da53376190480e063e24c7372b6deb /dev-libs/yaz
parentMask new slot of yaz. (diff)
downloadgentoo-2-491956353236f738f561609f78d1e4d61a960369.tar.gz
gentoo-2-491956353236f738f561609f78d1e4d61a960369.tar.bz2
gentoo-2-491956353236f738f561609f78d1e4d61a960369.zip
Version bumps. v4 is pmasked for slotting.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yaz')
-rw-r--r--dev-libs/yaz/ChangeLog11
-rw-r--r--dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch25
-rw-r--r--dev-libs/yaz/yaz-3.0.53.ebuild56
-rw-r--r--dev-libs/yaz/yaz-4.2.30.ebuild56
4 files changed, 146 insertions, 2 deletions
diff --git a/dev-libs/yaz/ChangeLog b/dev-libs/yaz/ChangeLog
index fe100dab8d4e..6deac748cae5 100644
--- a/dev-libs/yaz/ChangeLog
+++ b/dev-libs/yaz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/yaz
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.69 2011/01/16 10:39:05 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/ChangeLog,v 1.70 2012/04/22 21:07:10 robbat2 Exp $
+
+*yaz-3.0.53 (22 Apr 2012)
+*yaz-4.2.30 (22 Apr 2012)
+
+ 22 Apr 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/yaz-4.2.30-icu-automagic.patch, +yaz-3.0.53.ebuild, +yaz-4.2.30.ebuild:
+ Version bumps. v4 is pmasked for slotting.
06 Nov 2010; Mark Loeser <halcy0n@gentoo.org> yaz-3.0.50.ebuild:
Stable for ppc64; bug #328707
diff --git a/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch b/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch
new file mode 100644
index 000000000000..e6854448b513
--- /dev/null
+++ b/dev-libs/yaz/files/yaz-4.2.30-icu-automagic.patch
@@ -0,0 +1,25 @@
+diff -Nuar yaz-4.2.30.orig/configure.ac yaz-4.2.30/configure.ac
+--- yaz-4.2.30.orig/configure.ac 2012-03-23 10:20:20.000000000 +0000
++++ yaz-4.2.30/configure.ac 2012-04-22 20:56:41.118691087 +0000
+@@ -372,14 +372,13 @@
+
+ dnl
+ dnl
+-AC_CHECK_ICU([3.4],[
+- if test "$xml_enabled" = "true"; then
+- ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
+- else
+- ICU_CPPFLAGS=""
+- AC_MSG_WARN([ICU support disabled because XML support is unavailable])
+- fi
+-])
++AC_ARG_ENABLE(icu, [ --enable-icu enable ICU support],[enable_icu=$enableval],[enable_icu=no])
++if test "$enable_icu" = "yes"; then
++ AC_CHECK_ICU([3.4],[
++ ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"],[
++ AC_MSG_ERROR([For ICU support please install libicu34-dev or similar])
++ ])
++fi
+ dnl ------ versioning
+ dnl
+ WIN_FILEVERSION=`echo $PACKAGE_VERSION | $AWK 'BEGIN { FS = "."; } { m = $4; printf("%d,%d,%d,%d", $1, $2, $3 == "" ? "0" : $3, $4 == "" ? "1" : $4);}'`
diff --git a/dev-libs/yaz/yaz-3.0.53.ebuild b/dev-libs/yaz/yaz-3.0.53.ebuild
new file mode 100644
index 000000000000..d10b35a5e864
--- /dev/null
+++ b/dev-libs/yaz/yaz-3.0.53.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-3.0.53.ebuild,v 1.1 2012/04/22 21:07:10 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}
diff --git a/dev-libs/yaz/yaz-4.2.30.ebuild b/dev-libs/yaz/yaz-4.2.30.ebuild
new file mode 100644
index 000000000000..b73566eaba45
--- /dev/null
+++ b/dev-libs/yaz/yaz-4.2.30.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-4.2.30.ebuild,v 1.1 2012/04/22 21:07:10 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.2.30-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}