summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-08 06:59:48 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-08 06:59:48 +0000
commit05925e6a78e9a87154d8ab4580064df931069bc9 (patch)
treed9e304b59f6d9484ce161daed10ec51e1f193ab4 /dev-libs
parentRemove old versions. (diff)
downloadgentoo-2-05925e6a78e9a87154d8ab4580064df931069bc9.tar.gz
gentoo-2-05925e6a78e9a87154d8ab4580064df931069bc9.tar.bz2
gentoo-2-05925e6a78e9a87154d8ab4580064df931069bc9.zip
Fix building against pthreads-win32 (bug #407371, thanks to Nathan Phillip Brink (binki)).
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libxml2/ChangeLog7
-rw-r--r--dev-libs/libxml2/files/libxml2-2.7.8-windows-thread_t.patch30
-rw-r--r--dev-libs/libxml2/libxml2-2.7.8-r5.ebuild5
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index 74253b528033..785d62e50c97 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxml2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.336 2012/03/03 19:45:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.337 2012/03/08 06:59:48 tetromino Exp $
+
+ 08 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libxml2-2.7.8-r5.ebuild, +files/libxml2-2.7.8-windows-thread_t.patch:
+ Fix building against pthreads-win32 (bug #407371, thanks to Nathan Phillip
+ Brink (binki)).
03 Mar 2012; Raúl Porcel <armin76@gentoo.org> libxml2-2.7.8-r5.ebuild:
arm/ia64/m68k/s390/sh/sparc stable wrt #405261
diff --git a/dev-libs/libxml2/files/libxml2-2.7.8-windows-thread_t.patch b/dev-libs/libxml2/files/libxml2-2.7.8-windows-thread_t.patch
new file mode 100644
index 000000000000..7916917005e3
--- /dev/null
+++ b/dev-libs/libxml2/files/libxml2-2.7.8-windows-thread_t.patch
@@ -0,0 +1,30 @@
+From d794a84a9e147498069b4c582d57b899bf068187 Mon Sep 17 00:00:00 2001
+From: "Andrew W. Nosenko" <andrew.w.nosenko@gmail.com>
+Date: Mon, 15 Nov 2010 13:00:29 +0100
+Subject: [PATCH] 599241 fix an initialization problem on Win64
+
+as the thread_t is not an integral datatype on that platform
+---
+ testThreads.c | 6 ++----
+ 1 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/testThreads.c b/testThreads.c
+index b43cbd0..bff5391 100644
+--- a/testThreads.c
++++ b/testThreads.c
+@@ -105,10 +105,8 @@ main(void)
+ for (repeat = 0;repeat < 500;repeat++) {
+ xmlLoadCatalog(catalog);
+
+- for (i = 0; i < num_threads; i++) {
+- results[i] = NULL;
+- tid[i] = (pthread_t) -1;
+- }
++ memset(results, 0, sizeof(*results)*num_threads);
++ memset(tid, 0xff, sizeof(*tid)*num_threads);
+
+ for (i = 0; i < num_threads; i++) {
+ ret = pthread_create(&tid[i], NULL, thread_specific_data,
+--
+1.7.8.5
+
diff --git a/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild b/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild
index d06bb45519c7..27668e6f6c04 100644
--- a/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild
+++ b/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild,v 1.8 2012/03/03 19:45:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.7.8-r5.ebuild,v 1.9 2012/03/08 06:59:48 tetromino Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -93,6 +93,9 @@ src_prepare() {
# Make hash functions less predictable to prevent DoS
epatch "${FILESDIR}/${P}-hash-randomization.patch"
+ # Fix building against pthreads-win32, bug #407371
+ epatch "${FILESDIR}/${P}-windows-thread_t.patch"
+
# Please do not remove, as else we get references to PORTAGE_TMPDIR
# in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
# We now need to run eautoreconf at the end to prevent maintainer mode.