summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-18 17:00:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-18 17:00:43 +0000
commit1e5804730a87dcb3858582102cbc57581a3a8d5e (patch)
tree11500a0e00f9bbc7be9848ea8f64c6d99a2c928d /dev-libs
parentppc/ppc64 stable wrt #382641 (diff)
downloadgentoo-2-1e5804730a87dcb3858582102cbc57581a3a8d5e.tar.gz
gentoo-2-1e5804730a87dcb3858582102cbc57581a3a8d5e.tar.bz2
gentoo-2-1e5804730a87dcb3858582102cbc57581a3a8d5e.zip
old
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/soprano/ChangeLog6
-rw-r--r--dev-libs/soprano/soprano-2.4.4.ebuild110
-rw-r--r--dev-libs/soprano/soprano-2.5.3.ebuild85
-rw-r--r--dev-libs/soprano/soprano-2.6.0.ebuild85
-rw-r--r--dev-libs/soprano/soprano-2.6.51.ebuild90
5 files changed, 5 insertions, 371 deletions
diff --git a/dev-libs/soprano/ChangeLog b/dev-libs/soprano/ChangeLog
index 495ff0db1bca..2ac31a73b99c 100644
--- a/dev-libs/soprano/ChangeLog
+++ b/dev-libs/soprano/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/soprano
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.80 2011/10/18 16:59:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/ChangeLog,v 1.81 2011/10/18 17:00:43 ssuominen Exp $
+
+ 18 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -soprano-2.4.4.ebuild,
+ -soprano-2.5.3.ebuild, -soprano-2.6.0.ebuild, -soprano-2.6.51.ebuild:
+ old
18 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> soprano-2.7.0.ebuild:
ppc/ppc64 stable wrt #382641
diff --git a/dev-libs/soprano/soprano-2.4.4.ebuild b/dev-libs/soprano/soprano-2.4.4.ebuild
deleted file mode 100644
index ed6d58f93ce0..000000000000
--- a/dev-libs/soprano/soprano-2.4.4.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.4.4.ebuild,v 1.11 2011/10/17 14:27:33 jer Exp $
-
-EAPI="2"
-
-JAVA_PKG_OPT_USE="java"
-inherit base cmake-utils flag-o-matic java-pkg-opt-2
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://soprano.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD java +raptor +redland test +virtuoso"
-
-RESTRICT="test" #331761
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-1.4.16
- <media-libs/raptor-1.9.0 )
- redland? (
- >=dev-libs/rasqal-0.9.15
- >=dev-libs/redland-1.0.10
- )
- java? ( >=virtual/jdk-1.6.0 )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
-)
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
-
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} SVN tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use java && ! use virtuoso; then
- if ! use redland; then
- echo
- ewarn "You have explicitly disabled the default soprano backend and haven't chosen"
- ewarn "a different one. Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable any of those USE"
- ewarn "flags:"
- ewarn "java (deprecated), redland, virtuoso (recommended)"
- echo
- else
- echo
- ewarn "You selected redland as the only backend for soprano."
- ewarn "Be advised that it's known to be broken (bug #275326)."
- echo
- fi
- fi
-}
-
-src_prepare() {
- base_src_prepare
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !java SOPRANO_DISABLE_SESAME2_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_test() {
- mycmakeargs+=(-DSOPRANO_BUILD_TESTS=ON)
- cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
-}
diff --git a/dev-libs/soprano/soprano-2.5.3.ebuild b/dev-libs/soprano/soprano-2.5.3.ebuild
deleted file mode 100644
index b91be987b055..000000000000
--- a/dev-libs/soprano/soprano-2.5.3.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.5.3.ebuild,v 1.3 2011/10/17 14:27:33 jer Exp $
-
-EAPI="3"
-
-JAVA_PKG_OPT_USE="java"
-inherit cmake-utils flag-o-matic
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://soprano.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
-
-RESTRICT="test" #331761
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-1.4.16
- <media-libs/raptor-1.9.0 )
- redland? (
- >=dev-libs/rasqal-0.9.15
- >=dev-libs/redland-1.0.10
- )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
-)
-
-pkg_setup() {
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} SVN tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use virtuoso; then
- echo
- ewarn "You have explicitly disabled the default soprano backend."
- ewarn "Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable"
- ewarn "the virtuoso USE flag."
- echo
- fi
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- $(cmake-utils_use test SOPRANO_BUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}
diff --git a/dev-libs/soprano/soprano-2.6.0.ebuild b/dev-libs/soprano/soprano-2.6.0.ebuild
deleted file mode 100644
index f7d20ba2e276..000000000000
--- a/dev-libs/soprano/soprano-2.6.0.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.6.0.ebuild,v 1.8 2011/10/17 14:27:33 jer Exp $
-
-EAPI=3
-
-inherit cmake-utils flag-o-matic
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://soprano.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
-
-RESTRICT="test"
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-1.4.16:0 )
- redland? (
- >=dev-libs/rasqal-0.9.15
- <dev-libs/rasqal-0.9.20
- >=dev-libs/redland-1.0.10
- <dev-libs/redland-1.0.12
- )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
-)
-
-pkg_setup() {
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} SVN tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use virtuoso; then
- echo
- ewarn "You have explicitly disabled the default soprano backend."
- ewarn "Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable"
- ewarn "the virtuoso USE flag."
- echo
- fi
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- $(cmake-utils_use test SOPRANO_BUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}
diff --git a/dev-libs/soprano/soprano-2.6.51.ebuild b/dev-libs/soprano/soprano-2.6.51.ebuild
deleted file mode 100644
index ab2d5e2e16ab..000000000000
--- a/dev-libs/soprano/soprano-2.6.51.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/soprano/soprano-2.6.51.ebuild,v 1.3 2011/10/17 14:27:33 jer Exp $
-
-EAPI=4
-
-if [[ ${PV} == *9999* ]]; then
- git_eclass="git-2"
- EGIT_REPO_URI="git://anongit.kde.org/soprano"
- KEYWORDS=""
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-inherit base cmake-utils flag-o-matic ${git_eclass}
-
-DESCRIPTION="Library that provides a nice Qt interface to RDF storage solutions"
-HOMEPAGE="http://sourceforge.net/projects/soprano"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="clucene +dbus debug doc elibc_FreeBSD +raptor +redland test +virtuoso"
-
-COMMON_DEPEND="
- >=x11-libs/qt-core-4.5.0:4
- clucene? ( dev-cpp/clucene )
- dbus? ( >=x11-libs/qt-dbus-4.5.0:4 )
- raptor? ( >=media-libs/raptor-1.4.16:0 )
- redland? (
- >=dev-libs/rasqal-0.9.15
- <dev-libs/rasqal-0.9.20
- >=dev-libs/redland-1.0.10
- <dev-libs/redland-1.0.12
- )
- virtuoso? ( dev-db/libiodbc:0 )
-"
-DEPEND="${COMMON_DEPEND}
- doc? ( app-doc/doxygen )
- test? ( >=x11-libs/qt-test-4.5.0:4 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtuoso? ( >=dev-db/virtuoso-server-6.1.0 )
-"
-
-CMAKE_IN_SOURCE_BUILD="1"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-make-broken-redland-fatal.cmake"
-)
-
-pkg_setup() {
- if [[ ${PV} = *9999* && -z $I_KNOW_WHAT_I_AM_DOING ]]; then
- echo
- ewarn "WARNING! This is an experimental ebuild of ${PN} Git tree. Use at your own risk."
- ewarn "Do _NOT_ file bugs at bugs.gentoo.org because of this ebuild!"
- echo
- fi
-
- if ! use virtuoso; then
- echo
- ewarn "You have explicitly disabled the default soprano backend."
- ewarn "Applications using soprano may need at least one backend"
- ewarn "to be functional. If you experience any problems, enable"
- ewarn "the virtuoso USE flag."
- echo
- fi
-}
-
-src_configure() {
- # Fix for missing pthread.h linking
- # NOTE: temporarily fix until a better cmake files patch will be provided.
- use elibc_FreeBSD && append-flags -pthread
-
- local mycmakeargs=(
- -DSOPRANO_BUILD_TESTS=OFF
- -DCMAKE_SKIP_RPATH=OFF
- -DSOPRANO_DISABLE_SESAME2_BACKEND=ON
- $(cmake-utils_use !clucene SOPRANO_DISABLE_CLUCENE_INDEX)
- $(cmake-utils_use !dbus SOPRANO_DISABLE_DBUS)
- $(cmake-utils_use !raptor SOPRANO_DISABLE_RAPTOR_PARSER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_RAPTOR_SERIALIZER)
- $(cmake-utils_use !redland SOPRANO_DISABLE_REDLAND_BACKEND)
- $(cmake-utils_use !virtuoso SOPRANO_DISABLE_VIRTUOSO_BACKEND)
- $(cmake-utils_use doc SOPRANO_BUILD_API_DOCS)
- $(cmake-utils_use test SOPRANO_BUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}